PSIM

SIMULADOR DE CONVERSORES
ESTATICOS



1. INTRODUCAO

A simulagdo de circuitos estd ficando cada vez mais aceita como uma ferramenta normal do
projeto de equipamentos de eletronica. Este material tem o objetivo de fazer uma breve introdugédo a
utiliza¢do do simulador de circuitos elétricos PSIM. O uso da simulagdo € reconhecido como uma
necessidade prética, tornando-se uma ferramenta indispensdvel na formacdo de técnicos e
engenheiros, principalmente na parte referente a projetos e interpretacdo de equipamentos
eletroeletronicos.

O método pratico para verificar o projeto de um circuito elétrico € construi-lo e testa-lo. No
entanto, isso pode se tornar caro e consumir muito tempo. Como alternativa, o circuito pode ser
cuidadosamente simulado usando um programa de computador antes da implementagao do circuito
real.

O PSIM € um programa de simulag¢do especialmente projetado para eletronica de poténcia.
Com interface amigdvel, simulacdo rdpida, e apresentacdo de formas de onda semelhante a tela de
um osciloscopio, o PSIM mostra ser um ambiente de simulacdo poderoso para a andlise de
conversores de poténcia, malhas de controle e estudo de acionamento de motores. Além disso, o
simulador pode perfeitamente ser utilizado em praticamente todos os tipos de circuitos, sejam eles
digitais ou analdgicos.

O PSIM ¢é muito util para simular quase todos os tipos de circuitos, cobrindo uma enorme
faixa de aplicagdes. Um circuito é descrito por comandos armazenados em arquivo chamado de
“arquivo de circuito”, que € lido pelo simulador PSIM. Os comandos sdo faceis de aprender e usar.

Os conceitos elétricos sao gerais e Uteis para todos os tamanhos de circuitos. O simulador
ndo diferencia um circuito grande de um pequeno ou microvolts e megavolts, pois sao apenas
nimeros para o PSIM. E mais, o simulador nao avalia como o circuito deveria se comportar.
Logo, vocé deve analisar os resultados para ver se eles correspondem com a teoria.

Para circuitos discretos (circuitos feitos de partes individuais montadas sobre um circuito), o
PSIM tem uma variedade de usos, dos quais se destacam:

e Verificar uma idéia de circuito antes de monta-la em laboratdrio. Os resultados de simulacdo
sdo livres de instabilidade de tensdo e corrente, restricoes de aterramento, € outros
problemas de laboratério.

e Realizacdo de testes ideais, que consiste na operacdo empregando componentes ideais para
isolar efeitos limitantes no seu projeto.

e Realizacdo de medidas dos testes simulados que sdo dificeis de serem realizadas na prética
por serem:

o  Dificeis (devido a ruidos elétricos ou carga do circuito);
o  Inconvenientes (equipamento especial de teste ndo € disponivel);
o Imprudentes (o circuito de teste pode se destruir).

e Possibilidade de simular um circuito vdrias vezes com variagdes de componentes para
verificar que percentual passaria no teste final, e determinar quais as combinacdes dao os
resultados para o pior caso.

® Projeto de sistemas de controle de conversores estiaticos em malha fechada (com sistema de
controle), sem a necessidade de se projetar todo o circuito de controle.



Uma vez familiarizado com o PSIM, vocé achard que ele pode substituir a maioria de seus
trabalhos de laboratério. Como qualquer nova ferramenta, um certo conhecimento é requerido para
tirar o maior proveito.

O PSIM ¢€ disponibilizado, na forma de uma demonstracdo (com recursos limitados) no site:
http://www.powersimtech.com/download.asp?file=demo/psim8.0.1 demo.zip

2. ESTRUTURA DO SIMULADOR

O simulador, uma vez instalado, apresenta dois programas executdveis: o PSIM, que € o
editor de esquemas elétricos € o simulador de circuitos, e SIMVIEW, que demonstra graficamente
as formas de onda obtidas na simulac@o. Os icones dos programas estdo representados na figura
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Figura 1 - Icones dos programas

O simulador utiliza algumas extensdes caracteristicas para os arquivos gerados por ele, que

sdo:
Extensio  Descrigio Tipo de arquivo
sch Esquemas do PSIM binario
cet Lista de nods do esquema texto
txt Saida da simulacio texto
fra Saida de uma analise AC texto
SV Lista de forma de ondas bindrio

O programa € em inglés. Desta forma, todos os numeros devem ser digitados utilizando-se
um ponto como separador decimal, ao invés da virgula utilizada em portugués, ou seja, deve-se
digitar 34.56 e nao 34,56.

Para facilitar a digitacdo de nimeros muito grandes ou muito pequenos, o PSIM aceita
algumas letras indicando multiplos e submultiplos. Na tabela a seguir estdo relacionados os sufixos
aceitos.

Sufixo Nome Valor
pico 107"°

n nano 10°°

u Micro 107

m mili 10~
K ouk kilo 107
M mega 107

G giga 107




3. 0 EDITOR DE ESQUEMATICOS

Executando-se o programa PSIM, tem-se a tela do editor de esquematicos. Na Figura 2 estd
representada a tela principal do programa, mostrando seus principais botdes.
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Figura 2 — Tela principal do PSIM

Na parte superior o programa apresenta um menu de opgdes, € uma barra de ferramentas
com alguns botdes de atalho. Na tabela abaixo estdo descritas as funcdes destes botdes:

O Criar arquivo.

= Abrir arquivo.

= Salvar arquivo.
= Imprimir arquivo.

&4 Recortar selecio.

Copiar selecio.

B Colar.

= Copiar selecdo para a area de transferéncia (usado para passar
= desenhos para outros programas, como um editor de texto).
2 Gira a selegdo.
a0 Inverter horizontalmente a selegio.
®1 Inverter verticalmente a selegfo.

7 Inserir ligacdes.




Inserir marcadores (para conectar dois ou mais pontos do
circuito sem utilizar ligagGes).
=, Ferramenta de selego.
i) Zoom. Aumentar.
0o Zoom. Diminuir,
3 Zoom. Selecdo.
0 Zoom. Ajusta apagina.
[ Iniciar a simulacdo.
(=] Cancelar a simulagio. Somente disponivel durante simulagdes.
2| Abrir o programa de visualizagio das formas de onda.
A Adicionar um texto no esquema eletronico.
Iﬁ Para adicionar rapidamente um componente do mesmo tipo de
M algum dos ultimos ja adicionados.

No PSIM, todos os componentes estdo dispostos no menu Elements. Os elementos estdo
divididos em quatro grupos:

e Power (poténcia): Elementos do circuito de poténcia, como chaves semicondutoras,
resistores, indutores e capacitores;

e Control (controle): Elementos de controle, como filtros e componentes de eletronica
digital;
* Sources (fontes): Fontes de tensao e corrente

¢ Other (outros): Elementos adicionais, que sdo os controladores diretos das chaves
semicondutoras, sensores, instrumentos de medi¢do, elementos de interface entre
poténcia e controle, e elementos comuns aos circuitos de poténcia e controle;

Na parte inferior do programa estd uma barra de ferramentas, com botdes de atalho para
alguns dos componentes disponiveis.

+ [terra @ | fonte de tensdo CC

A | resistor ‘¢ | fonte de tensdo senoidal
-~ | indutor “ra | fonte de tensdo triangular
— | capacitor " | fonte de tensdo quadrada
—+ | diodo *an | degrau de tensio
- | tiristor 1| sensor de tensdo
ik | MOSFET Ly-| sensor de corrente
I [IGBT ganho proporcional
T#F | ponte de diodos monofasica ganho proporcional-integral
{5f | ponte de diodos trifisica 3@ subtrator
comando de chaves 3gr| somador

A [interface controle/comando de chaves multiplicador




@ | voltimetro -2 divisor

‘| voltimetro diferencial | comparador
*® | amperimetro 7 limitador

A |porta inversora

O PSIM divide a simulagdo entre o circuito de poténcia e o circuito de controle. A Figura 3
mostra o circuito de um retificador de 12 pulsos controlado, onde se mostra a divisdo entre os
circuitos de poténcia e de controle. E importante destacar os seguintes elementos no circuito de
poténcia, que nao sdo usuais nos simuladores baseados no SPICE:

e Fontes de tensdo senoidais trifdsicas. O PSIM possui modelo de fontes trifdsicas
simétricas e equilibradas;

e Transformadores trifasicos com ligacdo Y-Y e Y-A;

e Pontes retificadoras trifasicas a tiristor;
e (argas RL;

e Voltimetros (V) e amperimetros (A), usados para medir a tensdo e corrente instantanea,
respectivamente.

PSIM - [C: Arquivos de programas'PSIMY examplesiinterphase transformer.sch] = |ﬁ'|1|
Flle Edit ¥iew Subcircuit  Elements  Simulate  Options  Window  Help . =l |

DIDIQ@ tlmlelal o el alsloln] @) = Al :I\

....... T ¥ Controle da (i S B S S
....... i L Dole . retificadores em. ponte. com CE = g o gl o S e 2 O th e o Tkt @R w
s SImU|agaO através de indutor de J.nterfase ............................

T R e ot e I Y s M Y R R R R Ko e K R B o o s 3 A e e P e e

[

Figura 3 — Circuito exemplo mostrando os principais blocos do PSIM



O circuito de controle também € simplificado, podendo ser implementado através de
diagrama de blocos. Observa-se neste circuito:

Um bloco que implementa um filtro passa-baixas (LP_filter). Existem blocos para
implementar leis de controle, tais como blocos PI, PID, multiplicadores, somadores,
divisores, valor rms, controle digital, etc;

A presenca de comparadores (representado como um amplificador operacional). E
importante ressaltar que, normalmente, estes elementos ndo funcionam como
amplificadores operacionais;

A existéncia de elementos para geracdo de comando (no caso, o angulo de disparo dos
tiristores). Este elemento, neste caso, também faz ligacao do circuito de controle para o
circuito de poténcia. O sinal de comando para acionar os semicondutores, neste
simulador, € do tipo 16gico (0=off, 1=on);

A utilizacdo de fontes para a geracdo de valores constantes (fonte cc), formas de onda
triangular, quadrada, senoidais, etc;

A utilizacdo de Voltimetros (V) também podem ser usados para verificar as varidveis
internas do circuito de controle;

A ligacdo entre os circuitos de poténcia e controle se dd através de sensores de tensdo e
sensores de corrente, e entre os circuitos de controle e poténcia através de controladores de
acionamento ou elementos de ligagdo (ndo mostrados na Figura 3). E importante destacar que um
sinal de poténcia nio pode ser ligado diretamente no circuito de controle. E indispensével o uso
de um sensor entre eles.

E importante destacar o controlador de simulacdo. Este controlador é obrigatério, pois nele
sdo definidos os tempos de simulacdo e o passo de simulacdo. Mais detalhes serdo mostrados a

seguir.

4. PRIMEIRA SIMULACAO

A melhor forma de se aprender a trabalhar em um simulador de circuito € fazendo
simulacdes. Fazer algumas simulagdes requer varios fundamentos, ou seja, € necessdrio:

Criar o arquivo de entrada, ou arquivo do circuito;
Rodar o simulador;

Inspecionar os resultados obtidos;

Inicialmente é mostrado, na Figura 4, um simples retificador monofdsico com filtro
capacitivo para introduzir o funcionamento do PSIM. Isto mostrard os fundamentos de uma
simulacao de circuito de forma breve para entdo rapidamente se atingir um resultado bem sucedido.
Este circuito ndo possui nenhum interruptor controlado, sendo somente formando por um circuito
de poténcia.
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Figura 4 — Esquemadtico de um retificador a diodo no PSIM

Para desenhar o circuito no PSIM, utiliza-se o seguinte procedimento:

1. Criar um novo arquivo. Isto é feito indo-se no menu File -> New, ou simplesmente

[

clicando-se no botao

2. Iniciar a inserir os componentes. Para inserir a fonte de tens@o senoidal, seleciona-se no
menu Elements -> Sources -> Voltage -> Sine. Observe que existem varios tipos de
fontes no PSIM, tanto de tensdo quanto de corrente. Outra op¢do para a fonte de tensao

senoidal € utilizar o botao Iﬁ[, presente na barra de ferramentas inferior do programa.
Com isso, o cursor do mouse fica com a forma do componente. Para rotacionar o
componente em 90°, basta clicar com o botdo direito do mouse. Para colocar o
componente em um determinado lugar da drea de edigcdo, basta clicar com o botdo
esquerdo do mouse.

Mesmo apds a colocacdo do componente, o cursor do mouse permanece com a forma do
componente, permitindo que seja inserido outro componente igual. Para retornar ao

cursor normal, deve-se pressionar a tecla ESC, ou utilizar o botao % , na barra de
ferramentas superior. Outra opg¢do € selecionar outro componente, ou outra ferramenta
de edicao.



3. Editar os parametros dos componentes. Uma vez que o cursor do mouse esteja com sua
forma normal, podem-se selecionar as propriedades de um componente dando-se dois
cliques sobre o mesmo. Com isso, uma janela com as propriedades aparecerd na tela. As
propriedades variam, de acordo com o componente selecionado. Na Figura 5 estdo
representados os parametros da fonte de tensdo continua. No caso, pode-se alterar o
nome e o valor do componente, e definir se estas propriedades devem ou nao aparecer no
esquema. Além disso, podem-se alterar outras informacdes sobre o componente (other
info), e a cor (color) do mesmo. Entretanto, as informagdes adicionais (other info) e a
cor do componente (color) ndo afetam os resultados da simulagdo. A opg¢do display ao
lado de cada item permite que o parametro seja mostrado no esquemaético do circuito.

VSIN (3
Parameters | Other Infa | Colar |
Sirmzoidal voltage source M
Display

Mame "ﬂi r
Peak Armplitude ’3117 I
Frequency ’507 I
Phase Angle ’Ui ul
DC Offset m
Tstart lﬂi r

Figura 5 — Parametros da fonte de tensao alternada
4. Para os demais componentes, repetem-se 0s passos 2 e 3.

5. Inserir o componente que indica o ponto de referéncia (terra) do circuito. Este
componente ¢ importante, pois serve de referéncia para as medi¢des realizadas. Sua
insercdo € obrigatdria, pois caso ndo seja colocado este ponto de referéncia, o simulador

informara que ocorreu um erro. Este componente estd no menu Elements -> Other ->

Ground. Outra opcdo é utilizar o botio *, presente na barra de ferramentas inferior do

programa.

6. Conectar os componentes. Para realizar as conexdes, primeiramente seleciona-se a

ferramenta apropriada, clicando-se no botdo o+ , na barra de ferramentas superior. com
isso, o cursor do mouse fica com o formato de um lapis. Para conectar dois pontos, clica-
se com o botdo esquerdo do mouse no primeiro ponto, € mantendo-se pressionado o
botdo do mouse, leva-se o cursor até o segundo ponto, e solta-se o botdao. Pode-se notar
que o programa realiza até uma curva de 90°.

7. Selecionar as variaveis de saida. A selecdo dos pontos do circuito que o programa ird
adicionar ao arquivo de saida é feita através da adi¢do de instrumentos de medida. Para
observar-se tensdo, deve-se utilizar um dos dois tipos de voltimetro disponiveis: um que
mede a tensdo de um determinado né em relacdo ao componente terra, e o diferencial,
que mede a tensdo entre seus dois terminais. Esses componentes estdo no menu
Elements -> Other -> Probes -> Voltage Probe / Voltage Probe (node-to-node),
respectivamente. Outra opc¢ao € utilizar os botdes e, presentes na barra de ferramentas
inferior do programa. Além disso, para a medi¢do de corrente, existem duas opg¢des: a
utilizacdo de amperimetro ou selecionando nos parametros do componente. O



componente amperimetro estd no menu Elements -> Other -> Probes -> Current
Probe e na barra de ferramentas inferior do programa, no botdo. A maioria dos
componentes apresenta em seus parametros o item Current Flag, onde é possivel
selecionar O (sem medicdo de corrente) ou 1 (com medicdo de corrente). Neste caso, a
medida da corrente neste elemento serd automaticamente efetuada. Na Figura 6 estdo
representados os parametros de um resistor, que apresenta o item Current Flag.

X

Parameters |Dlher|nfu| Colaor |

Riegistor Help |

Cizplayp

W |H1 [ ]
Hezistance |5 H
Current Flag ID ‘Fl

Figura 6 — Parametros de um resistor

8. Salvar o arquivo. Para salvar o arquivo com o circuito desenhado, pode-se utilizar os

comandos File -> Save / Save As, ou o botdo H, na barra de ferramentas superior.
Desta forma ird aparecer a janela padrao do windows para salvar arquivos, onde pode ser
alterado o caminho e o nome do arquivo. O arquivo deve ser salvo com a extensao .sch.

Na Figura 5 esta representado o retificador desenhado no PSIM. Pode-se notar nesta figura o
nome e o valor dos componentes, bem como a posi¢do dos voltimetros e amperimetros.

®

€
Observacao: o voltimetro do tipo —/— tem como referéncia o Ground —[ especificado no
circuito, enquanto J@ ¢ utilizado para medir a diferenca de potencial entre os nés do

desenho. Assim como para utilizar-se 0 amperimetro ]ﬁl deve-se abrir o circuito e inseri-lo
em série com 0 mesmo.

Para que o circuito possa ser simulado € necessario definir os parametros de simula¢do do
mesmo. Para isso, € necessdrio incluir o controle de simulacdo, localizado no menu Simulate ->
Simulation Control. Depois de ser adicionado ao esquema, uma tela com os seus pardmetros €
mostrada. Na Figura 7 estd representada esta tela, cujos parametros sdo explicados na tabela a
seguir.
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Figura 7 — Parametros para simulacao

Time Step Passo utilizado na simulacdo, em segundos.
Total Time Tempo total da simulacdo, em segundos

Tempo inicial para salvar os dados, antes de a simulagcdo atingir este
Print Time tempo, nenhum dado € salvo.

Passo para salvar os pontos. Se 1, todos os pontos sdo salvos. Se 10,
Print Step apenas 1 em cada 10 pontos € salvo. Isso ajuda a reduzir o tamanho do

arquivo de saida.
Para ler os valores iniciais. Se 1, o simulador ira ler os valores iniciais de

Load Flag um arquivo com a extensao ssf.
Para salvar os valores finais. Se 1, o simulador ira salvar os valores
Save Flag finais da simulacdo em um arquivo com a extensao ssf.

Com os parametros da simulag¢do definidos, pode-se simular o circuito. Isso é realizado

através do botdo ¥ , na barra de ferramentas superior. Na barra inferior do programa ird surgir um
indicativo do percentual da simulacdo ja atingido. Além disso, o botdo apertado ird mudar seu

desenho para ° Este botao podera ser utilizado agora para parar a simulacao. Uma vez terminada
a simulacdo, pode-se executar o programa Simview. Para isso, existe na barra de ferramentas

. . B2 . .

superior o botao J Pode-se configurar o programa PSIM para que ele automaticamente execute o
Simview quando as simulacdes terminarem. Para isso, deve-se selecionar o item Auto-run
SIMVIEW, no menu Options.

S. VISUALIZANDO OS RESULTADOS

Executando-se o programa SIMVIEW, tem-se a tela do mostrador de formas de onda. Na
figura a seguir estd um exemplo da tela principal deste programa, obtida apds a simulacdo de um
circuito.

Na tela inicial, mostrado na Figura 8, hd uma janela onde estdo relacionadas todas as
medidas disponiveis para serem mostradas. Estas medidas sdo aquelas definidas no circuito
desenhado no PSIM. Abaixo estd a janela obtida para o circuito desenhado na se¢do anterior.
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Figura 8 — Tela de abertura do SIMVIEW

Na tela inicial hd uma janela, onde estdo relacionadas todas as grandezas disponiveis para
serem mostradas. Estas grandezas s@o aquelas definidas no circuito desenhado no PSIM. Abaixo
estd a janela obtida para o circuito desenhado na se¢do anterior.
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Figura 9 — Janela para seleciao de formas de onda

Para adicionar uma forma de onda deve-se seleciond-la e clicar no botdo Add. Por outro
lado, para retirar uma forma de onda ja selecionada, basta seleciond-la e clicar no botdao Remove. A
Figura 10 mostra o resultado de simulagao.
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Figura 10 — Resultado obtido na simulacao (tensao VL, corrente il.)

Também é possivel realizar funcdes matemadticas simples entre as varidveis disponiveis.
Para isso deve-se utilizar o campo de edi¢do presente na parte inferior da janela. Como exemplo,
mostraremos o grafico da poténcia instantanea de saida VL*IL:

Ao abrir a tela inicial do SIMVIEW | na janela Data Display Selection ¢ possivel localizar
as ferramentas de edi¢do matemaética no canto inferior esquerdo da janela.

Data Display Selection (=)

Wariables Available

‘Wariables for Dizplay

a8 | Cancel |

Figura 11 - SIMVIEW ferramentas de edicio matematica

Seleciona-se entdo a varidvel VL, clicando em seguida no botdo :' , depois seleciona-se a
operacdo matematica clicando no botio e entdo a préxima varidvel IL. Note que a caixa
de texto preenche-se com a férmula matematica editada. Novamente utilizamos o botdo Add e
verificamos que a formula passa para a caixa de texto da esquerda Variables for Display. Finaliza-
se com o botao OK. A Figura 12 mostra o resultado obtido.

Pode ocorrer a necessidade, depois de selecionadas as varidveis apresentadas no exemplo
acima, de adicionar outra varidvel. Caso esta varidvel ja tenha sido medida na simulacdo, nao é
necessdrio executar a simulacdo novamente, basta ir até o menu Screen -> Add/Delete Curve.
Caso contrario, sera necessario se incluir um sensor e se simular novamente.
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Figura 12 - Poténcia instantanea na carga

O programa SIMVIEW também permite que possam ser exibidos outros graficos de
simulacdo. Vamos como exemplo adicionar o grafico da tensdo de entrada em uma outra tela. Neste
caso, basta selecionar o menu Screen -> Add Screen. Como resultado, obtém-se as duas formas de
onda mostradas de forma concomitante, como mostra a Figura 13.

180.00 190.00 200.00 210.00 220.00
Time (ms)

Figura 13 — Exemplo de miiltiplas formas de onda



Para modificar a escala dos eixos pode-se utilizar dos botdes

XY
como mostrado na

9

Figura 14. Um exemplo da aplicagdao dessa ferramenta serd mostrado mais adiante na secdo de

Analise Espectral.

X Axis Setting
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Mo of Division |4

2200081 " Log Range

Escala (valor inicial e final)

Grid Division | Nimero de divisdes da grade

Scale Escala linear ou logaritimaca

Cancel

Figura 14 — Janela de escala do eixo X

Por default o fundo da tela do SIMVIEW ¢ preto, para modificar para branco, no caso da

necessidade de geracdo de um documento para impressdo basta clicar no menu: Option -> Set
Background -> Black / White.

Também pode ser necessario enviar o grafico para a drea de transferéncia, para isto procede-
se da seguinte forma: Clique no menu Edit -> Copy to Clipboard. E entio utilize a op¢do Colar
ou Paste no editor de texto ou grafico de sua preferéncia.

Na parte superior o programa apresenta um menu de opg¢des, e alguns botdes de atalho. Na
tabela abaixo estio descritos os comandos dos botdes da barra de tarefas superior:

Abrir arquivo.

m |w,

Imprimir.,

e

Copiar para a drea de transferéncia (usado para passar as formas
de onda para outros programas, como um editor de texto).

=
H
H]
H

Reabrir o arquivo atual.

Redesenhar os dados.

Ferramenta de zoom.

Para abrir a caixa de medigdes, e habilitar os botdes de medicio.

Para configurar as escalas do eixo horizontal.

Para configurar as escalas do eixo vertical.

Para adicionar formas de onda ao grafico atual.

Para adicionar formas de onda, criando um novo grafico.

SEEE = e B

Para passar para o dominio da freqiiéncia.




Para passar para o dominio do tempo.

Ferramenta de selegio.

Adicionar texto.

'+ | Mostra o proximo valor maximo da varidvel selecionada.®

‘) | Mostra o valor minimo da variavel selecionada.®

£ | Mostra o préximo valor minimo da variavel selecionada.*

Mostra o valor médio da variavel selecionada.*

E
3
A
% | Mostra o valor maximo da variavel selecionada.*
i
b
et
X

sms | Mostra o valor eficaz da variavel selecionada.®

i | Mostra o valor médio do modulo da variavel selecionada.*

* disponivel apenas quando a caixa de medigdes esta na tela, e
uma variavel esta selecionada

Por exemplo, para saber o valor da tensdo sobre os resistores, pressiona-se 0 botdo x . .
Desta forma aparece uma janela com o nome Measure. Para que os valores aparecam nesta janela
basta clicar no grafico. Na figura a seguir esta representado o resultado obtido no exemplo.

Measure =
Time 1.93802e-1
IL 5.78466e+0
WL 2 89234e+2
Wd4 8.485853e-4

Figura 15 — Medidas obtidas na simulacao

6. ANALISANDO ESPECTRALMENTE OS RESULTADOS

O programa SIMVIEW permite a rdpida transformacao dos graficos do dominio do tempo

L, . A . . . - FFT .
para o dominio da freqii€ncia, para isso basta clicar no botao . Deve-se tomar cuidado com os
parametros indicados na simulacdo como o Time Step, Total time e Print time, pois o usudrio
pode nao verificar a formagao correta do espectro de freqiiéncias.

Tomando uma sendide pura no caso da tensdo de entrada Vp = 311V - S0Hz , temos um
periodo igual a T = 20ms. Logo, deve-se preencher campo Total Time com o valor 0.02. Caso
contrdrio ndo se analisard um ciclo inteiro, ou mais de um ciclo, que resulta em erros.

Observe o exemplo com uma andlise espectral incorreta. Tomando-se a simulacdo do
retificador com filtro capacitivo, definiu-se Print Time com o valor 0.18 para eliminar o
comportamento transitorio na andlise. Neste caso, definiu-se o tempo final de simulacdo em Total
Time com o valor 0.23, que corresponde a 2 ciclos e meio da entrada. Empregando-se o comando

J e fazendo os ajustes de escala no eixo X, chega-se na resposta mostrada na Figura 16.
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Figura 16 — Analise espectral realizada de forma incorreta. (a) Dominio do tempo (b) Espectro

Observa-se na Figura 16 que o espectro encontrado nao € o correto para a sendide. Observe
que para uma sendide pura o valor médio de tensdo € nulo, e no gréafico apresenta um nivel CC.

Por outro lado, observa-se na Figura 17 que foi realizada uma andlise espectral com periodo

correto para tensdo a ser analisada. Neste caso, empregou-se no campo Print Time o valor 0.18 e
no campo Total Time o valor 0.20.
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Figura 17 — Analise espectral realizada de forma correta. (a) Dominio do tempo (b) Espectro

O resultado mostra que somente existe a componente harmodnica fundamental, como
esperado. Nota-se também que nao existe nivel CC, uma vez que a sendide possui valor médio nulo.
Na Figura 17(b) foi feita uma medi¢@o do valor de pico da componente harmonica fundamental, que
ocorre em S0Hz. Este € o valor de pico da sendide mostrada na Figura 17(a).

Analisando a tensao de saida, obtém-se o espectro mostrado na Figura 18. Podemos observar
que o espectro de harmonicas que existe nivel CC, componente continua de 300V. Também se nota
que aparecem multiplos pares da componente harmdnica fundamental. Isto se explica devido a
simetria par da funcdo, que pela teoria das Séries de Fourier resulta em harmonicas pares. Logo ha
componentes espectrais em 100Hz, 200Hz, 300Hz, 400Hz, etc.

Por fim, analisaremos na Figura 19 a forma de onda da corrente de entrada I1. Na Figura 20
observaremos que nio aparece uma componente continua, pois o valor médio da corrente de entrada



¢ nulo. Observe também que aparecem multiplos impares da harmonica fundamental devido a
simetria i{mpar da func@o.
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Figura 18 — Analise espectral da tensao de saida
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7. SIMULANDO UM CIRCUITO COM INTERRUPTORES
COMANDADOS

Neste exemplo serd mostrado o funcionamento de um retificador trifisico com
tiristores, empregando um retificador A-Y, como mostra a Fig. 21.

Figura 21 - Retificador Trifasico.

Este circuito contém uma fonte trifdsica na entrada. Esta fonte possui os seguintes
parametros: Tensdo de Linha (rms), Freqiiéncia e Angulo de Fase Inicial, como mostra a
Fig. 22.
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Figura 22 — Parametros da alimentacao trifasica.



Ap6s a fonte encontramos um transformador A — Y. Este transformador faz com que
a tensdo do secunddrio seja alterada em 30 graus com relacdo a tensdo de fase do primério,
além de modificar a sua amplitude. Os parametros deste transformador sdo mostrados na
Fig. 23:

x

Parameters I Other Inf-:ul Colar I

F-phaze DN tranzformer Help I

Diizplay
I arne ITF_ST
R p [prirmary] IW
Fiz [zecondam] IW
Lp [pn. leakage] IW
Lz [zec. lzakage] IW
Lm [rmagretizing] IEIE—
Mp [prirmary] I'I—
Mz [zecondany] I'I—

Figura 23 — Parametros do transformador A - Y.
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Por fim, o circuito de poténcia € composto por uma ponte retificadora trifasica
(mostrada em bloco unico) e de uma carga RL. Cabe destacar que os amperimetros e
voltimetros sdo usados para visualizar as varidveis do circuito simulado.

O circuito possui também um subcircuito de controle para geragdo dos pulsos de
disparo dos tiristores. Este sistema € sincronizado com as tensdes da rede, consistindo de um
sensor de tensdo (isolado) que mede V1s-V3s (tensdo entre a fase 1 e 3 na ligacdo Y). Esta
tensao € comparada com a referéncia gerando um pulso no semi-ciclo positivo (Vsync). Este
pulso de sincronismo € uma das entradas do controlador do dngulo de disparo alfa, que tem
como entrada também o angulo a do pulso, e uma entrada de ativagdo do controlador. Os
parametros deste controlador estdo mostrados na Fig. 24. Observa-se que a freqiiéncia e a
largura do pulso de disparo s@o definidas pelo usudrio.
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Figura 24 — Parametros do controlador de angulo de disparo.



Simularemos o circuito a fim de obtermos os graficos referentes ao seu
funcionamento.
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Figura 25 — Resultado da simulacdo do retificador trifasico. Tensao de linha secundaria,
tensao de sincronismo Vsync e pulso digital de disparo da ponte
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Figura 26 — Resultado da simulacdo do retificador trifasico: tensio e corrente de saida
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Figura 27 — Resultado da simulacao do retificador trifasico: tensao e corrente de entrada
(corrente com escala x5)

8. SIMULANDO UM CIRCUITO COM LEI DE CONTROLE

Neste exemplo serd mostrado o funcionamento de um retificador trifdsico com tiristores,
empregando uma lei de controle, tal como mostrado na Fig. 28.
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Figura 28 — Retificador trifasico operando em malha fechada



Este circuito descreve um retificado similar ao mostrado no exemplo anterior. Neste caso,
nao ha transformador e o filtro de saida é do tipo LC. Desta forma, a varidvel de saida ¢ do tipo
fonte de tensdo, e o que se deseja é obter uma tensdo de saida regulada, mesmo diante de variagdes
de carga. Em malha aberta, este circuito tem a resposta mostrada na Fig. 29. Observe que o circuito
possui regulagdo em regime permanente, mas a resposta transitéria € lenta.
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Figura 29 — Resposta de simulac¢ao do retificador trifasico operando em malha aberta

O mesmo circuito pode ser controlado em malha fechada. Através da operacdo em malha
fechada € possivel se modificar o angulo de disparo para obter-se uma resposta transitéria melhor.
A Fig. 30 mostra os resultados de simulacdo. Observa-se que a acdo de controle em malha fechada
resulta numa melhor resposta transitéria. Esta acdo de controle € limitada pelo angulo de disparo
minimo e méaximo. E importante ressaltar que sdo incluidos no controlador os blocos de saturagdo e
cos™. O primeiro é usado para impedir que os Angulos de disparos possuam valores fora da faixa de
atuagdo do conversor (menor que 0° ¢ maior que 360°). O segundo é empregado para linearizar a
acdo de controle, uma vez que a relagdo entre o angulo de disparo e a tensao de saida é nao-linear.
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Figura 30 — Resposta de simulacao do retificador trifasico operando em malha fechada
9. CONCLUSAO

Esta apostila é uma breve introdu¢do a simulacdo de conversores estiaticos comutados em
baixa freqiiéncia empregando o software PSIM. E importante destacar que o software é bastante
poderoso, podendo ser usado para testar varios tipos de conversores e controladores. O propdsito
deste material € servir como um suporte inicial para o aluno, ndo como um material completo.
Acredita-se que este material seja suficiente para que o aluno se ambiente com o programa e possa
aprender, por conta propria, os inimeros recursos do programa.



