Customizing a VI
Approximate Time
You can complete this exercise in approximately 30 minutes.

Background
You can choose one of many LabVIEW template VIs to use as a starting point when building VIs.
However, sometimes you need to build a VI for which a template is not available. This tutorial
teaches you how to build and customize a VI without using a template.

Overview
In the following exercises, you will open a blank VI and add structures and Express VIs to the
block diagram to build a new VI. You will build a VI that generates a signal, reduces the number
of samples in the signal, and displays the resulting data in a table on the front panel.
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Completed Exercise
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Step-by-Step Instructions
1. Opening a Blank VI
If no template is available for the VI you want to build, you can start with a blank VI and add
Express VIs to accomplish a specific task. Complete the following steps to open a blank VI:
a. In the Getting Started window, click the Blank VI link in the New section or press the
<Ctrl-N> keys to open a blank VI. A blank front panel and block diagram appear.

You also can open a blank VI by selecting File » New VI or by selecting File » New
and selecting Blank VI from the Create New list.
b. You can right-click any blank space on the front panel to
display a temporary version of the Controls palette. The
Controls palette appears with a thumbtack icon in the
upper left corner. Click the thumbtack to pin the palette
so it is not temporary.
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2. Adding an Express VI that Simulates a Signal
Complete the following steps to find the Express VI you will use and add it to the block diagram:
a. Click the Show Context Help Window button on the front panel or
block diagram toolbar to display the Context Help window. You also
can select Help » Show Context Help from either window to display
the Context Help window.

You also can press the <Ctrl-H> keys to display the Context Help window.
b. Display the block diagram. On the
Functions palette, select the Express
» Input subpalette and move the
cursor over one of the Express VIs.
When you move the cursor over a VI,
the Context Help window displays
information about that VI.
c. Use the information that appears in the Context Help window to find the Express VI
that can simulate a sine wave signal. Keep the Context Help window open.

d. Select the Simulate Signal Express VI and place it on
the block diagram. The Configure Simulate Signal
dialog box appears.
e. Move the cursor over the various options in the
Configure Simulate Signal dialog box, such as
Frequency (Hz), and Amplitude. Read the information
that appears in the Context Help window.
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f. Configure the Simulate Signal Express
VI to generate a sine wave with a
frequency of 10.7 and amplitude of 2.
The signal in the Result Preview
window changes to reflect the
configured sine wave.

g. Click the OK button to save the current configuration and close the Configure
Simulate Signal dialog box.
h. Move the cursor over the Simulate Signal Express VI and read the information that
appears in the Context Help window. The Context Help window displays
configuration information about the Simulate Signal Express VI.

i.

Save the VI as Custom VI.vi in an easily accessible location.
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3. Searching the Help and Modifying a Signal
Complete the following steps to use the LabVIEW Help to search for the Express VI that reduces
the number of samples in a signal:

a. Move the cursor over the Simulate Signal
Express VI and click the Detailed help link in
the Context Help window to display the
Simulate Signal topic in the LabVIEW Help.
You may have to scroll down in the Context
Help window to see the Detailed help link.

You also can access the LabVIEW Help by right-clicking a VI or function on the block
diagram or on a pinned palette and selecting Help from the shortcut menu or by
selecting Help » Search the LabVIEW Help.

b. Click the Search tab, enter sample
compression in the Type in the word(s) to
search for combo box, and press the <Enter>
key. This word choice reflects what you want
this Express VI to do—compress, or reduce,
the number of samples in a signal.

c. Double-click the Sample
Compression topic in the search
results to display the topic that
describes the Sample Compression
Express VI.
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d. After you read the
description of the
Express VI, click the
Place on the block
diagram button to
place the Express VI
on the cursor.

e. Move the cursor to the block diagram.
f. Place the Sample Compression Express
VI on the block diagram to the right of
the Simulate Signal Express VI.

g. Configure the Sample Compression Express VI to
reduce the signal by a factor of 25 using the mean
of these values.
h. Click the OK button to save the current
configuration and close the Configure Sample
Compression dialog box.

i.

Use the Wiring tool to wire the Sine
output of the Simulate Signal Express VI
to the Signals input of the Sample
Compression Express VI.
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4. Customizing a User Interface from the Block Diagram
In the previous exercises, you added controls and indicators to the front panel using the
Controls palette. You also can create controls and indicators from the block diagram. Complete
the following steps to create controls and indicators from the block diagram:

a. On the block diagram, right-click the
Mean output of the Sample
Compression Express VI and select
Create » Numeric Indicator from
the shortcut menu to create a
numeric indicator. A Mean indicator
appears on the block diagram.

b. Right-click the Mean output of the Sample Compression Express VI
and select Insert Input/Output from the shortcut menu to insert
the Enable input.

In a previous exercise you learned to add inputs and outputs by expanding the
Express VI using the down arrows. Using the shortcut menu is a different way of
displaying and selecting the inputs and outputs of an Express VI.

c. Right-click the Enable input and select Create » Control from the
shortcut menu to create a switch. A Boolean control appears on the
block diagram.
Control terminals have a thicker border than indicator terminals. Also, an arrow
appears on the right of the terminal if the terminal is a control, and an arrow
appears on the left of the terminal if the terminal is an indicator.
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d. Right-click the wire that connects
the Sine output of the Simulate
Signal Express VI to the Signals input
of the Sample Compression Express
VI and select Create » Graph
Indicator from the shortcut menu.
e. Use the Wiring tool to wire the
Mean output of the Sample
Compression Express VI to the Sine
graph indicator. The Merge Signals
function automatically appears.
f. Arrange the objects on the block
diagram as shown.

g. Display the front panel. The controls and indicators you added appear on the front
panel with labels that correspond to the inputs and outputs from which you created.

You might need to scroll or resize the front panel to see all controls and indicators.

h. Arrange the objects on the front
panel as shown and run the VI.
i.

Toggle the Enable control and
run the VI again. Notice the Mean
indicator and Sine graph update.

j.

Save the VI.
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5. Configuring a VI to Run Continuously until the User Stops It
In the current state, the VI runs once, generates one signal, then stops running. To run the VI
until a condition occurs, you can use a While Loop. Complete the following steps to add a While
Loop to the block diagram:
a. Display the front panel and run the VI. The VI runs once and then stops.
b. Display the block diagram.
c. Click the Search button on the Functions palette
d. Enter While in the text box.
LabVIEW searches as you type and displays any matches in the search results text
box. LabVIEW displays a folder glyph to the left of subpalettes in the search results
and displays a light blue glyph to the left of Express VIs in the search results.

e. Double-click While Loop <<Execution
Control>> to display the Execution Control
subpalette and temporarily highlight the
While Loop on the subpalette.

f. Select the While Loop on the Execution Control palette.

g. Move the cursor to the upper left corner of the block diagram. Click to place the top
left corner of the While Loop. Drag the cursor diagonally to enclose all the Express
VIs and wires.
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h. Click to create the While
Loop around the Express
VIs and wires. The While
Loop appears with a
STOP button wired to
the conditional
terminal. This While
Loop is configured to
stop when the user
clicks the STOP button.
If all of the block diagram objects are not enclosed in the while loop, you can select
the objects and move them into the while loop.
i.

Display the front panel and run the VI. The VI now runs until you click the STOP
button. A While Loop executes the VIs and functions inside the loop until the user
clicks the STOP button.

j.

Click the STOP button and save the VI.

6. Using the Error List Window
If a VI contains an indicator you do not want to use, you can delete it. Complete the following
steps to remove the Mean indicator from the front panel:
a. On the front panel, move the cursor over the Mean indicator until the
Positioning tool appears.
b. Click the Mean indicator to select it and press the <Delete> key.
c. Display the block diagram.
d. A wire appears as a dashed black line with a red X in the middle. The
dashed black line is a broken wire. The Run button appears broken to
indicate the VI cannot run.
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e. Click the broken Run button to
display the Error list window.
The Error list window lists all
errors in the VI and provides
details about each error.
f. In the errors and warnings list,
select the Wire: has loose ends
error and click the Help button
to display more information.

You also can move the Wiring tool over a broken wire to display a tip strip that
describes why the wire is broken. This information also appears in the Context Help
window when you move the Wiring tool over a broken wire.

g. In the errors and warnings list, double-click the Wire: has loose ends error to
highlight the broken wire.
h. Press the <Ctrl-B> keys to delete the broken wire. Pressing the <CTRL-B> keys
deletes all broken wires on the block diagram.
You can press the <Delete> key to delete only the selected wire.
i.

Select View » Error List to display the Error list window. No errors appear in the
errors and warnings field.
You also can press the <Ctrl-L> keys to display the Error list window.

j.

Click the Close button to close the Error list window. The Run
button no longer appears broken.
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7. Controlling the Speed of Execution
To plot the points on the waveform graph more slowly, you can add a time delay to the block
diagram. Complete the following steps to control the speed at which the VI runs:
a. On the block diagram, search for the Time
Delay Express VI on the Functions palette and
place it inside the While Loop. You can use
the Time Delay Express VI to control the
execution rate of the VI.
b. Enter 0.25 in the Time delay (seconds)
text box. This time delay specifies how
fast the loop runs. With a 0.25 second
time delay, the loop iterates once every
quarter of a second.

c. Click the OK button to
save the configuration
and close the Configure
Time Delay dialog box.
d. Display the front panel
and run the VI.
e. Click the Enable switch
and examine the change
on the graph.
If the Enable switch is on, the graph displays the reduced signal. If the Enable switch
is off, the graph does not display the reduced signal.
f. Click the STOP button to stop the VI.
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8. Using a Table to Display Data
Complete the following steps to display a collection of mean values in front panel table:
a. On the front panel, search for the Express
Table indicator on the Controls palette and
place it on the front panel.
b. Display the block diagram. LabVIEW wired the
Table terminal to the Build Table Express VI.
c. If the Build Table Express VI and the Table terminal are not selected already, click an
open area on the block diagram to the left of the Build Table Express VI.
d. Drag the cursor diagonally until the selection rectangle
encloses the Build Table Express VI and the Table terminal. A
moving dashed outline highlights the Build Table Express VI,
the Table terminal, and the wire joining the two.
e. Drag the objects into the While Loop to the right of the
Sample Compression Express VI.
When you place an object in a While Loop near the border, the loop resizes to add
space for that object.
f. Wire the Mean output of the Sample Compression Express VI to the Signals input of
the Build Table Express VI.
g. Display the front panel and run the VI.
h. If the Enable switch is on, the table displays the mean values of every 25 samples of
the sine wave. If the Enable switch is off, the table does not record the mean values.
i.

Stop the VI.

j.

Experiment with properties of the table by using the Table Properties dialog box.
The Table Properties dialog box can be accessed if you right-click the table and
select Properties from the drop-down menu.

k. Save and close the VI.
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