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Processo Quando se olha de perto o processo a se automatizar, verifica-se que este é 
composto por uma série de pequenas áreas e sub-processos, que estão 
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composto por uma série de pequenas áreas e sub-processos, que estão 
interligados e dependentes uns dos outros. 

A primeira tarefa é portanto desmembrar o processo de automatização como um 
todo em pequenas sub-tarefas separadas. 

Hardware e Cada sub-tarefa define determinados requisitos tanto de hardware como de
Software software que têm que ser cumpridos pelo processo de automatização:

• Hardware:

- Número e tipo de entradas e saídas;
- Número e tipo de módulos;
- Número de bastidores;
- Capacidade e tipo da CPU; 
- Sistemas HMI; 
- Sistemas de interligação em rede.

• Software:

- Estrutura do programa;
- Tratamento de dados para o processo de automatização;
- Dados de configuração;
- Dados de comunicação;
- Documentação do programa e do projeto.

Projeto No SIMATIC S7 todos os requisitos de hardware e software de um processo de 
automatização são tratados dentro de um projeto. 

Um projeto incluí o hardware necessário (+ configuração), rede 
(+ configuração), todos os programas e o tratamento completo de todos os dados 
para uma solução com automação. 



Estrutura do  Os dados são armazenados num projeto sob a forma de objetos. Os objetos 
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Projeto são organizados no projeto numa estrutura de árvore (hierarquia do projeto). A 
estrutura em árvore mostrada na janela do projeto, é similar à do Windows 
Explorer. Somente os ícones dos objetos são diferentes. 

Hierarquia do 1º. Nível: •   O primeiro nível contém o ícone do projeto. Cada projeto   

Projeto representa a base de dados onde são armazenados todos os 
dados relevantes para o mesmo. 

2º. Nível: • As estações (por ex. estação S7-300) mostram onde estão 
armazenadas as informações sobre a configuração do hardware

e a atribuição de parâmetros aos módulos.                                   
As estações são o ponto de partida para configurar o hardware. •
As pastas “S7 Program” são o ponto de partida para a elaboração 
dos programas. Todo o software para um módulo parametrizável  
da gama S7 é armazenado numa pasta “S7 Program”. 
Estas contêm outras pastas para os blocos e arquivos fonte do 
programa. 

• Subredes (MPI,Profibus, Industrial Ethernet) são parte de uma 
rede completa.

3º. e subseqüentes níveis : Dependem do tipo de objeto do próximo nível
superior.



Introdução O SIMATIC Manager é uma interface de gráfica com o usuário para a edição 
online/offline de objetos S7 (projetos, arquivos de programa do usuário, blocos, 
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online/offline de objetos S7 (projetos, arquivos de programa do usuário, blocos, 
estações de hardware e ferramentas).
Com o SIMATIC Manager é possível:

• administrar projetos e bibliotecas;
• ativar as ferramentas STEP 7;
• acessar online o PLC;
• editar módulos de memória. 

Iniciando o Existe o ícone designado "SIMATIC Manager" no desktop do Windows, e um
SIMATIC Manager item de programa "SIMATIC Manager" dentro do campo SIMATIC no menu Iniciar. 

O programa é ativado como qualquer aplicação do Windows, através de duplo-click 
no ícone                  ou através do menu Iniciar

INICIAR -> SIMATIC ->

Interface Após a instalação, a ferramenta principal fica disponível com um ícone no desktop 
do Windows. O SIMATIC Manager administra os objetos S7 como projetos e 
programas de usuário.
Ao abrir um projeto, a ferramenta associada à edição é iniciada. Um duplo-click no 
bloco de programa inicia o editor de programa e um bloco pode ser editado.

Nota Sempre é possível obter ajuda online para a janela ativa pressionando-se a tecla de 
função F1.



Barra de Título A barra de título contém o título da janela e os botões para controlar essa mesma 
janela. 
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janela. 

Barra de Menu Contém todos os menus disponíveis para essa janela. 

Barra de Contém as tarefas que são utilizadas com maior freqüência sob a forma de

Ferramentas símbolos. Estes símbolos são auto-explicativos.

Barra de Status Mostra o estado de uma determinada aplicação e outras informações. 

Barra de Tarefas A barra de tarefas contém todas as aplicações que estão abertas e janelas como 
botões. 

A barra de tarefas pode ser posicionada em qualquer um dos lados da tela através 
da utilização do botão direito do mouse. 
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Criando um Projeto Selecione a opção de menu File -> New ou o símbolo na barra de ferramentas 
para abrir a caixa de diálogo "New“, que permite criar um novo projeto ou uma nova 
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para abrir a caixa de diálogo "New“, que permite criar um novo projeto ou uma nova 
biblioteca. 

Introduza o nome do projeto no campo "Name" e confirme selecionando "OK“.

Notas 1. O campo “Storage location (path)“ mostra o caminho configurado no 
SIMATIC Manager na sequência de menus Options -> Customize.

2. A partir do STEP 7 V3.2 existe um assistente (Wizard) para ajudar a criar 
um novo projeto. 



Inserindo um Selecione a sequência de menus Insert -> Program -> S7 Program para introduzir 

Programa um novo programa no projeto atual. 
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Programa um novo programa no projeto atual. 

Ao introduzir um objeto, o sistema atribui-lhe automaticamente um nome, por ex., 
"S7 Program(1)". 

Posteriormente é possível alterar este nome. 

Nota Utilize o método acima descrito para criar um programa independente de um 
hardware.

Programas relacionados a um hardware particular são tratados no capítulo sobre 
configuração de hardware.



Offline A opção offline mostra a estrutura do projeto armazenado no disco rígido do 
terminal de programação. Esta estrutura aparece na janela de projeto do SIMATIC 
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terminal de programação. Esta estrutura aparece na janela de projeto do SIMATIC 
Manager.

A pasta "S7 Program“ contém os objetos “Source Files" e "Blocks".

A pasta "Blocks" contém os dados de sistema criados a partir do HWConfig e os  
blocos criados com o Editor LAD/STL/FBD.

Online A opção online mostra a estrutura do projeto armazenado na CPU. Esta estrutura 
aparece na janela de projeto do SIMATIC Manager.

A pasta "S7 Program" contém apenas o objeto "Blocks".

A pasta "Blocks" contém:

• blocos de dados do sistema (SDB);

• blocos do programa do usuário (OB, FC, FB);

• blocos do próprio sistema (SFC, SFB).

Alternando A troca entre as opções de visualização offline e online é feita do seguinte modo:

• selecione o menu  View -> Offline ou View -> Online ou

• o correspondente símbolo na barra de ferramentas:

Online

Offline.



Introdução As bibliotecas são utilizadas para armazenar blocos que não estão associados a um projeto. 
Os blocos podem ser criados na biblioteca, podem ser copiados para dentro e fora dela, 
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Os blocos podem ser criados na biblioteca, podem ser copiados para dentro e fora dela, 
porém não podem ser testados. A estrutura da biblioteca é feita de forma hierarquizada 
como na estrutura de um programa. 

Standard Library O STEP 7 contém uma biblioteca standard, que está armazenada na pasta do software 
STEP 7, por ex. C:\Siemens\Step7\S7libs\stlib30, após o STEP 7 ter sido instalado. É 
possível acessar os blocos standard a partir do SIMATIC-Manager por “File ->Open -
>Libraries".

Communication FCs para comunicação entre a CPU e os I/O distribuídos através de 
Blocks processadores de comunicação com o S7-300.

Organization Blocks Blocos de Organização (OBs).

S5-S7 Converting Blocos para converter programas STEP 5.
Blocks

TI-S7 Converting Geralmente funções standard úteis, como tratamento de valores analógicos.
Blocks

IEC Function Blocos para funções IEC (IEC: International Electrotechnical Commission),
Blocks tais como processamento de hora e data, operações de comparação, processamento de 

strings e para seleção de máximo e mínimo. 

PID Control Blocks Blocos de Funções (FBs) para controle em malha fechada.

System Function Funções de Sistema (SFCs) e Blocos de Funções de Sistema (SFBs).
Blocks

Nota São adicionadas bibliotecas quando se instala algum software opcional.



Obtendo Ajuda Existem várias formas para se obter ajuda:

1. A ajuda geral é ativada através da seqüência de menus Help - > Contents.
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1. A ajuda geral é ativada através da seqüência de menus Help - > Contents.

2. A ajuda sensível ao contexto pode ser iniciada pressionando-se a tecla de 
função F1 ou através do símbolo         da barra de ferramentas. 

Opções • “Contents" - Mostra uma lista de tópicos de ajuda em títulos gerais.

• "Index" - Permite o acesso à informação de ajuda mostrando termos 
disponíveis por ordem alfabética. 

• “Find"  - Permite procurar por certas palavras ou expressões nos 
tópicos de ajuda. 

Hot words Algumas palavras estão escritas em verde e sublinhadas em tracejado nos textos 
de ajuda (são as chamadas "Hot words"). Clicando com o mouse nestas  "Hot 
words“ abre-se um novo texto de ajuda com informações detalhadas.  



Context-Sensitive Esta opção permite obter ajuda específica sobre os objetos, blocos, menus de 
comando, diálogos etc. que estão selecionados / ativos ao se acessar a seqüência 
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comando, diálogos etc. que estão selecionados / ativos ao se acessar a seqüência 
de menus Help - > Context-Sensitive Help. 

Pode-se passar do sistema de ajuda específico para a ajuda geral através do botão 
"Help on STEP 7".

Nota Pode-se encontrar informações suplementares sobre o STEP 7 nos manuais 
eletrônicos. Estes podem ser abertos ao se escolher a seqüência de menus Start -> 
Simatic -> S7 Manuals.



Objetivo Apagar um projeto existente e criar um novo. 
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O Que Fazer 1.  Inicie o SIMATIC-Manager.

2.  Apague o antigo projeto “Projeto_1” (se existente)

Selecione a seqüência de menus  File -> Delete -> User Projects.

3.  Selecione “Projeto_1“ da lista de projetos e confirme com OK.

4.  Depois do projeto ter sido apagado, selecione a seqüência de menus 
File -> New... -> User projects.

5.  No campo para atribuição do nome do projeto escreva “Projeto_1".

Notas Um projeto representa todos os componentes de um sistema de automação. Sendo 
assim, um projeto pode conter uma ou mais estações de hardware (controladores 
lógicos programáveis) e que, por exemplo, podem estar conectadas em rede 
trocando dados entre si.

Em cada estação, por outro lado, vários módulos inteligentes (módulos de função 
ou até 4 CPUs no caso do S7-400) podem ser instalados. Como regra, estes 
módulos possuem sua própria pasta de programa.

Adicionalmente é possível criar pastas de programas independentes de hardware, 
para que seja possível desenvolver uma aplicação antes de que se conheça (e 
posteriormente instale) esse hardware. Programas S7 independentes de hardware 
ou parte dos mesmos (por exemplo, blocos individuais) podem ser copiados 
posteriormente para a CPU sem nenhum problema, ou até mesmo podem ser 
copiados para outra pasta contendo outro programa.



Objetivo Inserir o programa S7 “Programa_1” no projeto criado no exercício anterior.
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O Que Fazer 1. No projeto “Projeto_1“, selecione a seqüência de menus Insert -> Program -> S7 
Program.

ou

1a. Clique com o botão direito do mouse sobre “Projeto_1”. No menu que aparece, 
selecione as opções Insert New Object -> S7 Program para inserir um novo programa.

2. É criado um novo programa S7 com o nome "S7 Program 1“.

3. Altere o nome do programa para “Programa_1“.

Resultado É criado um novo programa S7 dentro do projeto “Projeto_1“. É criado automaticamente 
dentro da pasta Blocks do programa um bloco OB1 vazio: 

Notas Um programa S7 contém os seguintes objetos:

• Blocks, no qual são armazenados os blocos (OBs, FCs, FBs e DBs), e que podem 
ser enviados para a CPU; 

• Sources, no qual são armazenados os programas fonte que são criados através de 
editores de texto, por exemplo, para STL, S7-SCL ou S7-HiGraph;

• Symbols, no qual são armazenados os simbólicos (nomes) para o endereçamento 
das variáveis globais do S7 tais como entradas, saídas, memórias, temporizadores e 

contadores. 

Lembre-se! Um programa S7 é uma combinação de blocos de programa, blocos de dados, comentários 
e símbolos que estão todos interligados dentro da aplicação. Quando se cria um programa 
cria-se uma estrutura que inclui todas estes elementos.



Notas As bibliotecas são utilizadas para armazenar blocos onde funções padronizadas 
foram implementadas. Os blocos podem ser copiados a partir da biblioteca para 
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foram implementadas. Os blocos podem ser copiados a partir da biblioteca para 
dentro de qualquer projeto e, quando necessário, renomeados (caso já exista um 
bloco com o mesmo número).

Objetivo Copiar o bloco FC105 da biblioteca "Standard Library" do STEP 7 para a pasta 
Blocks do “Programa_1” contido no projeto “Projeto_1” criado anteriormente.

O Que Fazer 1. Abra a "Standard Library" a partir do SIMATIC Manager: 
File > Open... -> selecione "Library" na caixa de diálogo -> escolha "Standard 

Library" na lista -> ok

2. Abra a pasta Blocks do programa "TI-S7-Converting Blocks"

3. No SIMATIC Manager, visualize os dois projetos (“Projeto_1" e "Standard 
Library“) ao mesmo tempo em duas janelas:
Window > Arrange > Horizontally

4. Copie o bloco FC 105 arrastando-o com o mouse para dentro da pasta de 
programa "Programa_1“.

Resultado O bloco FC 105 é armazenado na pasta Blocks do programa "Programa_1“, 
juntamente ao ainda vazio OB 1.



Objetivo Realizar um reset de memória na CPU e constatar se houve sucesso.
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O Que Fazer • Realize o reset de memória de acordo com os passos descritos acima.

• Verifique o resultado consultando  se restaram apenas os blocos de sistema 
na CPU (SDBs, SFCs, SFBs) 
no SIMATIC Manager, selecione a pasta "Programa_1" -> mude para o modo 

de visualização Online usando o ícone 

Notas No reset de memória todos os dados de usuário são apagados da CPU.

O reset pode ser realizado para se ter a certeza de que não restam blocos “antigos“ 
na memória. 

A CPU deve estar no estado STOP para se fazer um reset de memória:

• Seletor de modo de funcionamento em “STOP”; ou

• Seletor de modo de funcionamento em “RUN-P” e passagem para o estado  
STOP através da seqüência de menus  PLC -> Operating Mode -> Stop.

Durante um reset de memória:

• Todos os dados de usuário são apagados
(com exceção dos parâmetros MPI atribuídos).

• Teste de hardware e inicialização.

• Se estiver inserido um módulo de memória EPROM a CPU copia o 
conteúdo da mesma novamente para a RAM interna após o reset. 

• Se não estiver inserido nenhum módulo de memória, o endereço MPI 
anterior é mantido. Se, porém, estiver inserido um módulo de memória, é 

carregado o endereço MPI contido no módulo.

• O conteúdo do buffer de diagnóstico (pode ser visto no PG) é mantido.



Menu Options SIMATIC Manager -> Options -> Customize
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Opção “Language" • Language: Para selecionar a linguagem de utilização do SIMATIC Manager, 
menus, caixas de diálogo, ajuda, etc.
Só aparecem na lista as linguagens que foram instaladas.

• Mnemonics: Para selecionar os mnemônicos de utilização para programação 
dos blocos S7. 

Opção "General"  Opções básicas para edição de projetos e bibliotecas:
• Storage location for projects é onde se especifica o diretório onde serão 

armazenados os programas de usuário. 

• Storage location for libraries é onde se especifica o diretório onde serão 
armazenadas as bibliotecas de usuário. 

• Outras opções para inserção de objetos, abertura de projetos e para 
organização de janelas serão tratados mais tarde. 

• Deactivated system messages
Ao selecionar o botão “Activate“ pode-se reativar todas as mensagens de 
sistema que foram desligadas, quando a opção “Do not display this message“ 

foi escolhida.

Opção "View" Opções de exibição online. 

Opção "Columns"  Opções de exibição quando a visão detalhada é ativada (consulte o “Help“).

Opção "Archive" O arquivamento de projetos será discutido no capítulo “Documentando, Slavando, 
Arquivando“.


