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Funções de A diagnose é importante na fase de operação de um sistema ou de uma máquina.
Monitoração A diagnose ocorre usualmente quando um problema (falha) leva à uma parada ou a 
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Monitoração A diagnose ocorre usualmente quando um problema (falha) leva à uma parada ou a 
um incorreto funcionamento. 
Devido aos custos associados às paradas ou mal funcionamento, a causa da falha 
deve ser encontrada rapidamente e eliminada. 

Categorias de Erros Os erros que ocorrem podem ser divididos em duas categorias, dependendo se 
foram ou não detectados pelo PLC:

• Erros detectados pelo sistema operacional do PLC e normalmente levam a 
CPU ao estado Stop. 

• Erros de funcionamento, isto é, a CPU executa o programa normalmente, mas a 
função desejada ou não é executada completamente ou é executada 
incorretamente. 

A solução para estes tipos de erros é muito mais difícil, já que a causa é 
inicialmente difícil de ser determinada. 

As possíveis causas podem ser:

- Um erro de lógica de programação (erro de software), que não foi detectado 
durante o projeto e o startup e que ocorre em ocasiões extremamente raras.

- uma falha de processo, disparada pelo mal funcionamento de componentes 
diretamente associados ao controle do processo, desde cabos que ligam 
sensores / atuadores, como defeitos nos próprios sensores / atuadores.



Utilizando Existem várias funções de teste para procura de defeitos, dependendo do tipo de
Funções de Teste ... erro.
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Funções de Teste ... erro.

…com CPU em STOP Para erros detectados pelo sistema, as funções de teste Buffer de Diagnóstico, I 
STACK, B STACK, L STACK e Diagnóstico de Hardware dão informações 
detalhadas sobre a causa do erro e o ponto de interrupção. Através da 
programação de OBs de Erro (consulte o capítulo sobre Blocos de Organização), 
as informações sobre o erro ocorrido podem ser analisadas pelo programa e a 
transição da CPU para o estado STOP pode ser prevenida. A utilização das 
funções de teste Monitor / Modify Variable e Monitor Blocks não têm muito sentido, 
visto que a CPU nem lê nem transfere as imagens de processo no estado STOP, e 
também não executa o programa.

…com CPU em RUN Vice versa, não há muito sentido, como regra, utilizar funções de teste como o I 
STACK, B STACK ou L STACK para procura de defeitos quando a CPU está no 
modo RUN, já que a execução do programa não foi interrompida e o sistema não 
fornece nenhuma informação sobre o erro ocorrido. A função de teste Module 
Information somente fornece informações gerais sobre o modo de operação da  
CPU ou os erros que ocorreram no passado. Erros de funcionamento podem ser 
diagnosticados da seguinte forma:
• Falha de Processo (por exemplo erro de conexão)

- teste de conexão das entradas: Monitor Variable
- teste de conexão das saídas: Enable Peripheral Outputs (somente com a 

CPU em STOP) 
• Erros de Lógica de Programação (por exemplo escrita duplicada em um bit)

- Todas as funções de teste listadas, com exceção da função Enable 
Peripheral Outputs, podem ser utilizadas na busca de erros de lógica de 
programa.

Force Controle forçado de endereços independente da lógica do programa.

Breakpoints Para seguir a execução do programa passo a passo.

Ambas funções são utilizadas principalmente durante o projeto do programa.



Diagnóstico do Todas as funções de monitoração, de acordo com o correto funcionamento dos
Sistema componentes do PLC, estão agrupadas no Diagnóstico do Sistema. 
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Sistema componentes do PLC, estão agrupadas no Diagnóstico do Sistema. 
Todas as CPUs do S7 possuem um sistema de diagnóstico inteligente. A aquisição 
dos dados de diagnóstico não precisa ser programada. Ela está integrada no 
sistema operacional da CPU, e nos outros módulos com capacidade de 
diagnóstico, e é executada automaticamente.

Os erros ocorridos são armazenados (temporariamente) pela CPU no buffer de 
diagnóstico, e permitem uma diagnose direcionada e rápida, mesmo na ocorrência 
de erros esporádicos.

Reação do Sistema O sistema operacional toma as seguintes medidas quando detecta um erro ou um 
evento de STOP, como uma mudança de modo de operação (RUN -> STOP):

• Uma mensagem sobre a causa e o efeito do erro ocorrido é colocada no buffer 
de diagnóstico com data e hora.

O buffer de diagnóstico (“diagnostic buffer”) é um buffer FIFO no módulo da 
CPU para o armazenamento de eventos de erro. O tamanho do buffer de 
diagnóstico depende da CPU (por ex. CPU 314 = 100 eventos). 

Na estrutura FIFO do buffer, a mensagem mais recente sobrescreve a mais 
antiga. O buffer de diagnóstico não é apagado pelo reset de memória da CPU.

• A lista de status do sistema (“System status list”), que fornece informação sobre 
o status do sistema, é atualizada.

• O OB de erro associado ao erro é chamado. Isso dá oportunidade ao usuário de 
executar seu próprio tratamento de erro.

CPU Messages Se a CPU tiver de indicar a causa do STOP a todos os elementos de visualização 
associados (por ex. PG ou OP) durante a transição para STOP, a função "Report 
Cause of STOP" deve estar ativada dentro da propriedade da CPU 
"Diagnostics/Clock" na Configuração de Hardware.



Geral A informação da CPU auxilia na diagnose do sistema sem ter de fazer nenhuma 
programação, e torna possível a detecção e solução rápida de erros. 
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programação, e torna possível a detecção e solução rápida de erros. 

A informação necessária para a procura de defeitos é fornecida pela função:

PLC -> Module Information

Essa função pode ser acessada através do SIMATIC Manager ou através de outras 
ferramentas (pr ex. o Editor STL/LAD/FBD).

Module Information A função Module Information lê os dados mais importantes do módulo diretamente 
conectado. Ela está dividida nas seguintes seções:

General: Dentre outras informações, a descrição do módulo e as versões de  
hardware e firmware.

Diagnostic Buffer: Contém todos os eventos de diagnóstico na ordem em que 
ocorreram. Todos os eventos são listados em texto comum e ordenados na 
exibição.

Memory: Tamanho e utilização da memória EPROM de carga, memória RAM de 
carga e memória de trabalho.

Scan Cycle Time: Exibe o tempo de monitoração selecionado, o mais curto, o mais 
longo e o atual tempo de ciclo de scan.

Time System: Exibe o relógio de tempo real e o temporizador (“run-time meter”) 
integrado.

Performance Data: Exibe os blocos de sistema integrados e os blocos de 
organização disponíveis, assim como as áreas de endereçamento (I,Q,M,T,C,L).

Communication: Exibe os dados de performance das interfaces de comunicação e 
o resumo de conexões.

Stacks: Informações sobre os conteúdos do I Stack, B Stack e L Stack. Para isso, a 
CPU deve estar no estado STOP ou ter atingido um breakpoint.



Buffer de Diagnóstico O buffer de diagnóstico é um buffer FIFO armazenado numa área de memória da 
CPU protegida por bateria e que não pode ser apagada mesmo com um reset de 
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CPU protegida por bateria e que não pode ser apagada mesmo com um reset de 
memória. Ele contém todos os eventos de diagnóstico na ordem em que 
ocorreram.

Todos os acontecimentos podem ser visualizados no terminal de programação no  
formato texto e na ordem em que apareceram. 

Detalhes do Evento Ao selecionar um evento aparece informação adicional no campo "Details on 
Event": 
• ID e número do evento, 

• informação adicional, dependendo do evento, como por exemplo o endereço da 
instrução que originou essa situação, 

• etc.

Ajuda do Evento Ao clicar no campo , é fornecida a ajuda do evento selecionado. 

(Exemplo: ocorre um erro de programação, e o OB associado (OB 121) não está 
programado na CPU).  

Abrir Bloco Ao clicar no campo , pode ser aberto o bloco da CPU online no 
qual a interrupção ocorreu. (no exemplo acima: "FC 10").

Abrindo a Pode-se abrir o buffer de diagnóstico selecionando as opções de menu PLC -->
Ferramenta Module Information --> Diagnostic Buffer no SIMATIC Manager ou no Editor de 

Programa. 



Geral O último evento aparece no topo da lista. A hora exibe quais mensagens de erro 
estão agrupadas (eventos número 1 e 2 na figura).
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estão agrupadas (eventos número 1 e 2 na figura).

Interpretando Erros Em nosso exemplo, um restart completo foi feito antes de ocorrido o erro (eventos 
número 3 a 5). Após o restart, o erro ocorreu e originou as mensagens número 1 e 2.

Evento No. 1: a CPU vai para o modo STOP porque o OB relativo ao erro (OB 121) 
não estava carregado no controlador. 

A janela "Details" exibe o nível de processamento, por exemplo, OB 1 (Ciclo) assim 
como o bloco e o endereço da instrução que causou o erro (FC 18, endereço de 
bloco 80).

Evento No. 2: A causa atual do erro (erro de conversão BCD) é exibida aqui. Em  
"Details" pode-se observar que um número BCD inválido foi armazenado no 
Acumulador 1. Além disso, é exibido que o OB de erro (OB 121) é chamado pelo 
sistema operacional quando o erro ocorreu.

Obs de Erro Os seguintes OBs de erro estão disponíveis para o tratamento de falhas:

• OB 81: Falha de alimentação (falha de bateria de backup)

• OB 82: Interrupção de diagnóstico (quebra de fio, curto-circuito à terra em um 
módulo, etc)

• OB 84: Falha no hardware da CPU (nível de sinal incorreto na interface MPI,
apenas para o S7-400)

• OB 85: Erro de execução de programa (erro na atualização da imagem de 
processo)

• OB 86: Falha de rack de expansão ou escravo DP

• OB 87: Erro de comunicação (ID de frame incorreto)

• OB 121: Erro de programação (erro de conversão BCD, bloco chamado não 
disponível, etc.)

• OB 122: Erro de acesso (Operações de carga e transferência para I/O não 
existente ou defeituoso) 

Blocos de Organização são discutidos em detalhes em seu próprio capítulo!



Área de Utilização A função de teste "Monitor/Modify Variables" pode ser iniciada a partir do SIMATIC 
Manager ou a partir do Editor LAD/STL/FBD. Ela é utilizada para monitorar e / ou 
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Manager ou a partir do Editor LAD/STL/FBD. Ela é utilizada para monitorar e / ou 
modificar variáveis no formato desejado. 

Formato da VAT  As variáveis desejadas são colocadas em uma tabela de variáveis (“variable table” 
ou VAT). Com exceção das variáveis locais, temporárias, é possível monitorar e / 
ou modificar todas as variáveis ou endereços.
As colunas da tabela de variáveis a serem exibidas podem ser selecionadas 
utilizando o menu View e possuem os seguintes significados:

• Address: endereço absoluto da variável.

• Symbol: nome simbólico da variável 

• Symbol comment: comentário da variável exibida

• Display format: formato do dado escolhido pelo clique do mouse (por ex. 
binário, decimal...), no qual a variável é exibida.

• Status value: valor da variável no formato de status selecionado

• Modify value: valor a ser atribuído à variável

Salvando a VAT Uma tabela de variáveis criada pode ser salva utilizando Table -> Save ou Table -> 
Save as. Pode-se dar à tabela de variáveis qualquer nome escolhido, que é 
inserido como um nome simbólico na tabela de símbolos.
Tabelas de variáveis que foram salvas podem ser reutilizadas para monitoração e 
modificação, tornando desnecessário digitar novamente as variáveis a serem  
monitoradas. 

Nota Para checar a conexão elétrica das entradas e saídas (sem considerar o programa 
do usuário), pode-se acessar a função Monitor/Modify Variables diretamente a 
partir da ferramenta HWConfig (consulte o capítulo Configuração de Hardware)



Pontos de Trigger Pode-se estabelecer os pontos de trigger para a Monitoração e Modificação
utilizando Variable -> Set Trigger... ou utilizando o ícone exibido à esquerda.
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utilizando Variable -> Set Trigger... ou utilizando o ícone exibido à esquerda.
O ponto de trigger para monitoração (“Trigger Point for Monitoring”) define quando 
devem ser atualizados os valores das variáveis sendo monitoradas na tela. O ponto 
de trigger para modificação (“Trigger Point for Modifying”) define quando os valores  
de modificação devem ser associados às variáveis a serem modificadas.

Condição de Trigger A condição de trigger para monitoração (“Trigger Condition for Monitoring”) define 
se os valores devem ser atualizados na tela apenas uma vez no instante em que o 
ponto de trigger é atingido ou em todo ciclo (quando o ponto de trigger é atingido). 
A condição de trigger para modificação (“Trigger Condition for Modifying”) define se 
os valores de modificação devem ser associados às variáveis a serem modificadas 
uma vez ou em todo ciclo (toda vez em que o ponto de trigger é atingido).

Área de Utilização Os seguintes testes, dentre outros, podem ser implementados com a seleção 
apropriada de pontos de trigger e condições:
• Teste de conexão elétrica das entradas : (possível também no HW Config)

> Monitor Variable
Ponto de trigger: Beginning of Scan Cycle, Condição de trigger: Every Cycle

• Simulação do estado das entradas (de acordo com o usuário, independente 
do processo):
> Modify Variable
Ponto de trigger: Beginning of Scan cycle, Condição de trigger: Every Cycle

• Diferenciação entre erros de hardware / software
(um atuador que deveria estar ativado no processo não está controlado)
> Monitor Variable, para monitorar a saída relevante
Ponto de trigger: End of Scan Cycle, Condição de trigger: Every Cycle
(estado da saída = ´1´ > lógica de programa OK > erro de processo (hardware)
(estado da saída = ´0´ > lógica de programa com erro (poe ex. dupla atribuição)

• Controle das Saídas (independente da lógica de programa)
> Modify Variable
Ponto de trigger: End of Scan Cycle, Condição de trigger: Every Cycle



Área de Utilização Tabelas de variáveis que são armazenadas na pasta Blocks de um programa S7 
podem ser abertas novamente com um duplo clique futuramente para propósitos de 
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podem ser abertas novamente com um duplo clique futuramente para propósitos de 
teste.

Contudo, antes que as funções "Monitor" e "Modify" possam ser ativadas, deve-se 
estabelecer uma conexão online com a CPU.

As possibilidades seguintes estão disponíveis para esse propósito utilizando as 
opções de menu: PLC -> Connect to . . . ou clique nos ícones apropriados na barra 
de ferramentas:

CPU Configurada Se uma tabela de variáveis na pasta Blocks de um programa dependente de 
hardware for armazenada (associada a uma CPU na visualização do projeto), é 
estabelecida uma conexão com a estação com o endereço MPI configurado. Esse 
endereço, portanto, está associado ao endereço estabelecido na CPU com o 
auxílio da ferramenta HW Config.

Se a tabela de variáveis da pasta Blocks de um programa independente de 
hardware for armazenada (associada diretamente à raiz do projeto na visualização 
do projeto), o endereço MPI do programa independente de hardware pode ser 
estabelecido utilizando a caixa de propriedades (“Object Properties”) da pasta de 
programa durante a visualização online do SIMATIC Manager.

CPU Direta Uma conexão é estabelecida com a CPU que se encontra diretamente conectada 
ao PG através do cabo PG-MPI. O PG pode determinar qual estação está 
conectada através do cabo MPI.

CPU Acessível Nesse caso é exibida uma caixa de diálogo com a visualização do projeto, onde é 
possível selecionar uma pasta de programa. Uma conexão online é então 
estabelecida para a CPU configurada na pasta. 



Área de Utilização A função de teste Monitor Block é normalmente utilizada para seguir a execução do 
programa dentro de um bloco. Para isso, os estados ou conteúdos dos endereços 
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programa dentro de um bloco. Para isso, os estados ou conteúdos dos endereços 
utilizados no bloco no instante da execução do programa são exibidos na tela.

Monitor Pode-se ativar a função de teste "Monitor" ("Block Status") para o bloco aberto 
corrente no Editor LAD/STL/FBD clicando no ícone dos óculos ou selecionando 
Debug -> Monitor. 

No início da função de teste, é insignificante se o bloco a ser monitorado está 
aberto online ou offline no Editor. Contudo, se o bloco aberto offline não 
corresponder ao bloco online salvo na CPU, pode-se ou abrir o bloco salvo online  
ou transferir o bloco aberto offline para a CPU e após isso monitorá-lo.

No modo de teste, os estados dos endereços e os elementos em LAD / FBD são 
exibidos em diferentes cores. Para definir essas opções pode-se selecionar as 
opções de menu Options -> Customize: 

Exemplos:

• Status fulfilled (verdadeiro) -> "Element is displayed in green“ (verde)

• Status not fulfilled (falso) -> "Element is displayed in blue“ (azul)

Notas A exibição de status é ativada apenas quando a CPU está no modo RUN e as 
instruções a serem monitoradas estiverem sendo processadas!



Selecionando Ao monitorar blocos na linguagem STL, é possível selecionar quais informações 
as Informações serão exibidas na tela. Como default são exibidos os conteúdos do RLO, do Status 
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as Informações serão exibidas na tela. Como default são exibidos os conteúdos do RLO, do Status 
e do Standard (Acumulador 1).
• Pode-se selecionar quais informações serão exibidas como default utilizando as 

opções de menu Options > Customize > STL. 
• Durante a função de teste é possível escolher a qualquer momento a exibição 

ou não das informações na tabela utilizando o botão direito do mouse.

Informações • RLO: Resultado da Operação Lógica (“Result of logic operation”)

Exibidas • STAT: Status do endereço (binário)

• Default (Acumulador 1): Conteúdo do Acumulador 1

• Acumulador 2: Conteúdo do Acumulador 2

• AR1: Registrador de endereço 1 (“address register 1”), apenas relevante 
quando utilizado o endereçamento indireto

• AR2: Registrador de endereço 2 (“address register 2”), apenas relevante 
quando utilizado o endereçamento indireto

• DB Register 1 : Número do DB global ou do primeiro DB que está aberto

• DB Register 2: Número do DB local ou do segundo DB ou do DB instance que 
está aberto

• Indirect: Conteúdo do MD..., DBD... ou LD..., que está utilizada no 
endereçamento indireto de memória (por ex. a instrução L IW [MD 100] ).

• Status Word: Estado lógico dos Status Bits (OV, OS, BR, .........)

Formato de Pode-se selecionar o formato dos dados (decimal, hexadecimal, .....), no qual o
Exibição conteúdo do registrador será exibido utilizando o botão direito do mouse. Para isso 

basta clicar na coluna do Registrador com o botão direito do mouse e selecionar o 
formato do dado. 



Área de Utilização Para programas extensos, durante a procura de defeitos é particularmente 
necessário ter uma visão geral do local onde o endereço é lido e escrito, quais 
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necessário ter uma visão geral do local onde o endereço é lido e escrito, quais 
entradas e saídas são utilizadas, e como está estruturado todo o programa de 
acordo com a hierarquia de chamadas.

A ferramenta "Reference Data" fornece uma visão geral da estrutura do programa, 
assim como os endereços utilizados. Os dados de referência são gerados a partir 
do programa salvo offline.

Para erros de funcionamento, que podem significar erros de lógica de programação 
por exemplo (por ex. dupla atribuição), são úteis as ferramentas "Program Status“ e  
"Reference Data“, utilizadas em conjunto.

Se, por exemplo, uma operação lógica não for satisfeita devido a um bit de 
memória não setado, podem ser utilizados os dados de referência para determinar 
onde está associado este bit de memória.

Reference Data É possível ativar a criação e a exibição dos dados de referência no SIMATIC
…Generate Manager (quando a pasta "Blocks" está selecionada offline) ou no Editor
…Display LAD/STL/FBD utilizando Options -> Reference Data -> Display ou >Filter and 

Display.

…Filter Os dados de referência são constituídos de várias listas (veja a caixa Customize na 
figura) que são exibidas como dados filtrados (individualmente), (independente se o 
item Display ou Filter and Display foi selecionado no menu Options). Ao selecionar 
Display Reference Data, é possível escolher na caixa Customize qual lista será 
exibida primeiro. Depois é possível escolher qualquer uma dentre as diferentes 
listas.



Estrutura do A estrutura do programa descreve a hierarquia de chamadas dos blocos dentro do
Programa mesmo.
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Programa mesmo.

Filtro Dependendo da escolha do filtro, os caminhos do programa são exibidos em 
estrutura de árvore ou como "Parent/child structure" (em cada caso o bloco que faz 
a chamada e o bloco chamado são exibidos).

Símbolos Os símbolos a seguir estão disponíveis apenas na exibição em estrutura de árvore:

< maximum : nnn > • o tamanho máximo da memória (em bytes) de dados locais necessária é dado 
na raiz da estrutura de árvore.

[ nnn ] • por caminho, o tamanho máximo da memória (em bytes) de dados locais 
necessária é declarado no último bloco de cada caminho do programa.



Área de Utilização A Referência Cruzada (“Cross References”) fornece informações sobre como cada 
um dos endereços é utilizado e em quais blocos (com qual instrução). Além disso, 
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um dos endereços é utilizado e em quais blocos (com qual instrução). Além disso, 
pode-se encontrar, por exemplo, em que local no programa todo um bit de memória 
está (duplamente) atribuído. A referência cruzada é aberta utilizando View -> Cross 
References ou clicando no ícone aqui exibido à esquerda.

É possível exibir a referência cruzada para todas as entradas, saídas, bits de 
memória, temporizadores, contadores, blocos (exceto OBs), entradas e saídas de 
periferia.

Referência Cruzada Ao selecionar um endereço na lista de referência cruzada, pode-se abrir uma nova
de Endereços janela utilizando o botão direito do mouse e View -> Cross Reference for Address.
Individuais Essa janela contém apenas as referências cruzadas para este único endereço.

Estrutura A lista de referência cruzada está estruturada como uma tabela. Ela possui as 
seguintes colunas:

• Address: endereço absoluto do operando

• Symbol: nome simbólico do endereço

• Block: bloco no qual o endereço é utilizado

• Type: acesso de somente leitura (R) ou somente escrita (W)

• Language: linguagem de programação na qual o bloco foi criado

• Details: instrução que utiliza o endereço



Filtrando a Pode-se também exibir endereços individuais ou áreas de endereço
Referência Cruzada separadamente com a função de filtro. O acesso à caixa Filter reference data é feito 
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Referência Cruzada separadamente com a função de filtro. O acesso à caixa Filter reference data é feito 
através da opção de menu View.

As opções da caixa Filtro possuem os seguintes significados:

• Addresses
Determina qual o tipo de endereço a ser listado, desde que ativado o check box 
correspondente.

• Filter area
A área de filtro especifica a faixa de endereço a ser exibida. É possível 
especificar também várias áreas parciais. 
A área de filtro "10-50; 70; 100-130" significa que o endereço 70 e a faixa de 10 
a 50 e de 100 a 130 deve ser exibida.

• Access Type
Na opção default, todos os tipos de acesso são exibidos. Porém é possível 
escolher com a opção "Selection“ o tipo de acesso clicando nos check boxes; 
por exemplo – W – para acesso de somente-escrita.

• Columns
Clicando nos check boxes pode-se especificar o número e o conteúdo das 
colunas para o formato em tabela da lista de referência cruzada.

• Default Setting
Se as opções escolhidas tiverem de ser mantidas da próxima vez em que for 
iniciada a aplicação "Display Reference Data", deve-se ativar o check box "Save 
as standard". A opção básica ou aquela que foi salva como default é restaurada 
com o botão "Load Default Setting". 



Manuseando Com um clique duplo sobre um endereço na lista de referência cruzada, o Editor 
LAD/FBD/STL é iniciado, e aberto o bloco onde o endereço selecionado é utilizado. 
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LAD/FBD/STL é iniciado, e aberto o bloco onde o endereço selecionado é utilizado. 
O cursor posiciona-se sobre o network (LAD/FBD) ou na linha (STL) na qual o 
endereço está utilizado.

Nota Os dados de referência são gerados a partir dos blocos armazenados no modo 
offline!

Por essa razão, deve-se ter certeza de que os blocos armazenados online e offline
são idênticos para aprocura de defeitos. Pode-se checar isso no SIMATIC Manager 
utilizando  Options -> Compare Blocks.



Função e Durante a procura de defeitos, eventualmente é apenas necessário determinar
Área de Utilização onde um endereço está utilizado ou atribuído no programa. Neste caso, faz mais 
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Área de Utilização onde um endereço está utilizado ou atribuído no programa. Neste caso, faz mais 
sentido chamar a função "Go to Location" ao invés da lista de referência cruzada. A 
função Go to Location é chamada diretamente a partir do Editor LAD/FBD/STL e 
fornece um extrato da lista de referência cruzada para o endereço específico.
Ao selecionar a opção Overlapping Access to Memory Areas, os acessos word-por-
word a um endereço também são exibidos, por exemplo.

Manuseando Utilizando o botão direito do mouse, clique no endereço. A caixa de diálogo Go to 
Location aparece. Seus elementos possuem o mesmo significado daqueles 
contidos na referência cruzada.

Se um elemento for de interesse particular ou se um local de programa tiver de ser 
exibido, utiliza-se o botão Go To para abrir o bloco indicado com o Editor.

No exemplo acima interessa saber o lacal do programa onde a entrada I 0.2 está 
sendo lida (acesso do tipo leitura - “Access Type R”). Após a seleção da linha, 
pode-se abrir diretamente o FC 16, NW 1 utilizando o botão Go To. 

Ao clicar no botão Starting Point, retorna-se ao início.

Type of Access Como default, todos os acessos ao endereço são exibidos. Ao escolher a opção 
"Selection", pode-se exibir, por exemplo, acessos de somente escrita (atribuição, 
set, reset).



Find Enquanto os dados de referência são exibidos, é possível iniciar um busca por 
endereços (cadeia de caracteres) na lista atual. 
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endereços (cadeia de caracteres) na lista atual. 

Nota A função de busca trata-se de uma busca de texto pura, isto é, a descrição deve 
ser “exata - incluindo cada ponto, traço e espaço”. 

As opções adicionais são:

• busca por endereço, símbolo, bloco ou linguagem,

• A cadeia de caracteres escolhida como termo de busca compõe uma palavra 
completa ou é parte de uma palavra,

• letras maiúsculas / minúsculas são levadas em consideração ou ignoradas,

• a faixa de busca e a direção da busca podem ser especificados.



Assignment I/Q/M Pode-se abrir as atribuições de I/Q/M através das opções de menu View -> 
Assignment -> Inputs, Outputs and Bit Memory ou clicando no ícone 
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Assignment -> Inputs, Outputs and Bit Memory ou clicando no ícone 
correspondente.
Essa lista de atribuições fornece uma visão geral de quais bits são utilizados e em 
quais áreas de entrada (I), saída (Q) e bits de memória (M). 

Cada linha contém um byte da área de memória, na qual os oito bits estão 
identificados de acordo com o acesso. Pode-se ver também se o acesso é 
orientado a byte, orientado a word ou orientado a doubleword.

Significado dos identificadores na lista de atribuições I/Q/M:
• - o endereço não está utilizado a portanto ainda livre
• o o endereço é acessado diretamente 
• x o endereço é acessado por uma instrução de byte, word ou doubleword e 

portanto é utilizado indiretamente  

Assignment T/C Pode-se abrir as atribuições de T/C selecionando as opções de menu View -> 
Assignment -> Timers and Counters ou clicando no ícone correspondente. 
Essa lista de atribuições fornece uma visão geral de quais temporizadores e 
contadores são utilizados no programa. Dez temporizadores ou contadores são 
exibidos em cada linha.

Filtro Selecionando "Filter", pode-se escolher as áreas de memória a serem listadas e 
restringir as áreas de endereços individuais.
Aplicam-se as mesmas regras que para o filtro de Referência Cruzada.



Unused Symbols Ao selecionar as opções de menu View -> Unused Symbols ou clicando no ícone 
correspondente, aparece uma lista de endereços. Estes endereços estão definidos 
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correspondente, aparece uma lista de endereços. Estes endereços estão definidos 
na tabela de símbolos, porém não estão utilizados no programa.
Clicando com o botão direito do mouse e selecionando -> Delete Symbols, pode-se 
remover estes endereços ou símbolos da tabela de símbolos.

Addresses Ao selecionar as opções de menu View -> Addresses without Symbols ou clicando 
without Symbols no ícone correspondente, aparece uma lista de endereços. Estes endereços foram 

utilizados no programa, porém não estão definidos na tabela de símbolos. 

Clicando com o botão direito do mouse e selecionando -> Edit Symbols, podem-se 
declarar símbolos para o endereço referido. 

Filter Utiliza-se a função "Filter" para selecionar informações detalhadas para a exibição 
de símbolos não utilizados.



Função e A função "Enable Peripheral Outputs" somente pode ser ativada quando a CPU
Área de Utilização está no estado STOP. Ela habilita as saídas de periferia (PQ). Isso permite 
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Área de Utilização está no estado STOP. Ela habilita as saídas de periferia (PQ). Isso permite 
modificar o estado das saídas de periferia quando a CPU está no modo STOP.

A função "Enable Peripheral Outputs" é utilizada principalmente para checar a 
conexão elétrica das saídas de periferia. Ela pode, contudo, também ser utilizada 
para continuar a controlar os atuadores no processo, mesmo com a CPU no modo 
STOP devido à ocorrência de um erro.

O Que Fazer Para habilitar as saídas de periferia, proceda da seguinte forma: 

1. Abra ou edite uma tabela de variáveis (VAT) que contenha as saídas de 
periferia que devem ser testadas ou modificadas
(especificar as saídas de periferia byte-por-byte, word-por-word ou doubleword-
por-doubleword; não é possível modificar bits de saída individualmente!)

2. Selecione as opções de menu PLC -> Connect to… para estabelecer uma 
conexão com a CPU desejada

3. Modifique a CPU para o estado STOP

4. Entre com os valores apropriados para as saídas de periferia que devem ser 
modificadas na coluna "Modify Value". 

Exemplos: PQB 7 Modify Value: 2#01000011

PQW 2 W#16#0027

PQD 4 DW#16#0001

5. Use Variable -> Enable Peripheral Outputs para ativar a modificação das saídas

6. Use Variable -> Activate Modify Values para modificar as saídas de periferia.

7. Para associar os novos valores modificados, insira-os e ative-os com Variable 
> Activate Modify Values

A modificação ou a função "Enable Peripheral Outputs" permanece ativa até que 
seja desativada utilizando Variable -> Enable Peripheral Outputs ou pressionando a 
tecla ESC. 

Nota Ao modificar o modo de operação de STOP para RUN ou STARTUP, a habilitação 
das saídas de periferia é desativada e aparece uma mensagem.



Função e Com o Force, é possível sobrescrever as variáveis com quaisquer valores, 
Área de Utilização independente do programa. É possível apenas abrir apenas uma janela de valores 
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Área de Utilização independente do programa. É possível apenas abrir apenas uma janela de valores 
forçados para a CPU.

Com o S7-300, é apenas possível forçar as entradas e saídas na imagem de 
processo; com o S7-400 é possível ainda forçar bit memories e a elementos de 
periferia. 

Notas Sobre Forçar • Antes de iniciar a função "Force", deve-se estar certo que ninguém mais está 
executando esta função ao mesmo tempo na mesma CPU. 

• Pode-se apenas cancelar a função force selecionando as opções de menu  
Variable -> Stop Forcing

• Não se pode desfazer um ato de force através do menu Edit -> Undo. 

• Não é possível finalizar o force nem fechando a janela Force Values e nem 
saindo da aplicação "Monitor/Modify Variables". 

Selecionando a  1. A partir do SIMATIC Manager, selecione a CPU a ser forçada e as opções de
Função "Force" menu PLC -> Display Force Values. A partir disso a janela Force Values é 

aberta, contendo os endereços que estão atualmente forçados e seus valores 
atualmente atribuídos. A barra de status também exibe a data e hora do force 
corrente na CPU. Se nenhum endereço na CPU estiver forçado, a janela 
aparece vazia.

2. Na coluna "Address" insira as variáveis, e na coluna "Force Values" insira os 
valores desejados. 

3. Comece a forçar através da opção de menu Variable -> Force. 

4. Finalize o force com a opção de menu: Variable -> Stop Forcing.


