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Panorâmica A figura mostra as diferentes possibilidades de documentação possíveis. Todas 
as ferramentas de documentação possuem a função de imprimir.

Impressora A impressora utilizada para documentação é a mesma instalada no Windows. 
Para utilizar outra impressora, deve-se configurá-la através do Painel de 
Controle.

DOCPRO O software opcional DOCPRO também existe para documentação e para a 
elaboração de manuais.
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Comentários A figura acima mostra as diferentes possibilidades de comentários para um
de Blocos bloco de programa (OB, FC, FB).

Imprimindo Para imprimir:
• Clique no ícone da impressora ou 
• Selecione as opções de menu File --> Print. 

Configuração Pode-se alterar as opções para impressão através das opções de menu
File --> Print Setup.
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Configuração Selecionando as opções de menu File --> Page Setup surge uma caixa de 
diálogo na qual é possível selecionar o formato da impressão (por exemplo A4 
com margem).

Cabeçalhos/Rodapés A partir do SIMATIC Manager, pode-se configurar, para o projeto todo, os 
cabeçalhos e rodapés para toda a documentação.

Selecione as opções de menu File -> Labeling Fields para exibir a caixa de 
diálogo onde são definidos os textos para os cabeçalhos e rodapés. 
Também é possível preencher os campos de cabeçalhos e rodapés para a 
impressão da data, número da página ou o nome do objeto (por exemplo {Date} 
{Time}, Página {Page}, {Object}).
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Visualizar Impressão Para uma prévia do resultado da impressão, selecione as opções de menu
File -> Print Preview.

Nota A aparência da impressão depende das configurações feitas através das 
opções de menu Options -> Customize. 

Exemplo: A opção para o comprimento do campo de endereço afeta o número 
de contatos que podem ser exibidos lado a lado na impressão e o número de 
caracteres de um nome simbólico que preenchem uma linha acima dos 
contatos.
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Dados de Referência A impressão dos dados de referência torna a procura e solução de falhas mais 
fácil. Maiores informações podem ser encontradas no capítulo “Procura de 
Defeitos”.

Tabela de Símbolos A tabela de símbolos contém a associação entre o endereço absoluto, nome 
simbólico e comentário do símbolo. Consulte o capítulo "Símbolos“ para mais 
informações.

Configuração Dados sobre a configuração gerados a partir da ferramenta de Configuração de 
Hardware. A impressão é feita no formato texto. Para a impressão gráfica é 
necessário copiar os gráficos para a área de transferência, colá-los em outro 
programa, por exemplo, o Winword, e depois imprimir .

Configuração de Exibe de forma gráfica as estações de um sistema em rede com a configuração
Rede relevante, como por exemplo o endereço MPI.
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Função O STEP 7 oferece a possibilidade de gerenciar em várias línguas os textos e 
comentários criados para a documentação de um projeto. Eles podem ser 
exportados a partir do projeto para tradução e posteriormente importados na 
língua em que foram traduzidos. Sendo assim existe a possibilidade de 
selecionar entre as diferentes linguagens de documentação.

Os seguintes tipos de textos podem ser gerenciados em várias línguas:

• Títulos e comentários de blocos; 

• Títulos e comentários de networks;

• Comentários de linha em programas STL;

• Comentários de tabelas de símbolos, tabelas de declaração de variáveis, 
tipos de dados definidos pelo usuário e blocos de dados;

• Comentários, nomes de status etc. de blocos que foram criados com 
ferramentas de engenharia como o S7-GRAPH, S7-PDIAG  etc. 

Export A exportação é feita para todos os blocos e tabelas de símbolos localizadas no 
objeto selecionado. Para cada tipo de texto (observe acima), um arquivo de 
exportação é gerado e pode ser editado através do Excel. Este arquivo contém 
uma coluna com os textos fonte na língua original e uma coluna na qual os 
textos traduzidos podem ser escritos.

Import Durante a importação, o texto traduzido é aceito dentro do projeto selecionado. 
Os textos aceitos são aqueles que possuem seu correspondente na língua 
original.

Change Language Na mudança de linguagem, todas as linguagens importadas no projeto podem 
ser selecionadas. A mudança é aplicada a todos os projetos selecionados.

Delete Language Ao apagar uma linguagem, todos os textos são apagados de dentro dos dados 
do projeto.
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Carregando Com esta função, copia-se todos os blocos e os dados de sistema sem
o Programa documentação (tabela de símbolos, nomes de variáveis e de parâmetros,
da CPU para o PG comentários) da CPU para a pasta de programa selecionada. A pasta de 

programa selecionada, portanto, contém uma “cópia do PLC“ com o programa 
online atual.

Upload Station no PG Com esta função, basicamente é carregada toda a estação de hardware como 
uma nova estação no projeto. Não é possível sobrescrever uma estação já 
existente. 

Carga do Programa Os blocos e os dados de sistema contidos na pasta Blocks podem ser
do PG para o carregados no cartão de memória. O cartão de memória (ou “memory card”) 
Memory Card pode ser inserido na interface do PG ou no slot contido na CPU, se ela oferecer 

esta opção. 

Cópia do Programa Se o programa estiver armazenado dentro do cartão de memória, ainda é
da CPU para o possível efetuar mudanças online. Os blocos modificados são armazenados na 
Memory Card RAM interna da CPU, enquanto aqueles sem modificação permanecem 

armazenados dentro do cartão de memória. Pode-se posteriormente armazenar 
os blocos modificados dentro do cartão de memória com a função Copy RAM to 
ROM.

Arquivando o Projeto Todos os dados do projeto (programas, comentários, tabelas de símbolos,
no Memory Card configurações de hardware, etc. de todas as estações de hardware) são salvos 

no memory card com a função "Save Project on Memory Card". 

Arquivando o Projeto A função "Archive Project" salva todos os dados do projeto (programas, 
em Disquete comentários, tabelas de símbolos, configurações de hardware, etc. de todas as 

estações de hardware) em um arquivo em formato comprimido (*.zip, *.arj, etc.). 
O arquivo gerado é menor do que o conteúdo do projeto não-arquivado, e pode 
ser movido ou copiado através do Windows Explorer.
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Carregando um Normalmente ao fim do comissionamento é feita uma cópia da versão final do
Programa da programa no disco rígido do PG. 
CPU para o PG A melhor forma de fazê-lo é manter uma cópia do programa com comentários e 

símbolos no disco rígido antes de iniciar o comissionamento. Ao modificar o 
programa os blocos modificados também devem ser salvos no disco rígido, 
para que não sejam perdidos os comentários e símbolos.

Se o programa não estiver contido no PG, pode-se fazer o upload dos blocos da 
CPU. Nesse caso, os comentários e símbolos serão perdidos. É importante 
também fazer o upload dos blocos de dados de sistema (SDBs) por conterem 
os dados de configuração e comunicação.

O Que Fazer Para carregar o programa completo da CPU para o PG, execute os seguintes 
passos:
• Crie um novo programa S7 no SIMATIC Manager

• Clique no ícone "ON" online na barra de ferramentas

• Abra o programa S7 e selecione o objeto "Blocks" (programa do usuário)

• Selecione a opção de menu PLC --> Upload.

Nota: Os blocos são armazenados na pasta “Blocks” (programa do usuário) no 
disco rígido do PG.

Upload da Estação É possível também fazer o upload da estação completa para o PG, isto é, uma 
estação de hardware é criada no projeto. A vantagem disso é que é possível 
modificar os parâmetros de hardware imediatamente.

O que fazer:
• Crie um novo projeto no SIMATIC Manager.

• Selecione a opção de menu PLC -> Upload Station.
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Memória de Carga A memória de carga (“load memory”) faz parte do módulo programável. Ela 
contém objetos de carga criados no terminal de programação (blocos lógicos, 
blocos de dados, informações adicionais). 

A memória de carga pode ser um cartão externo inserido ou a RAM integrada. 

Memória de Trabalho A memória de trabalho (“work memory”) contém apenas os dados relevantes 
para execução. 
A memória de trabalho RAM está integrada na CPU e é mantida através de 
bateria.

Memória de Sistema A memória de sistema (“system memory”) contém áreas de memória para:
• Imagens de processo de entrada e saída (PII, PIQ)
• Bit memories (M)
• Temporizadores (T)
• Contadores (C)
• Pilha local (L stack) (L).

Memória Retentiva A memória retentiva é uma RAM não volátil utilizada para manter os bit 
memories, temporizadores, contadores e blocos de dados mesmo em caso de 
não existir bateria de backup. As áreas a serem mantidas são especificadas na 
parametrização da CPU.

Inserindo um Após a inserção do cartão de memória, o sistema operacional pede um reset de
Memory Card memória. (O LED STOP pisca vagarosamente). O reset é realizado colocando o 

seletor de modo na posição "MRES". As seções do programa que são 
relevantes para execução são então transferidas do cartão de memória (com a 
função de memória de carga) para a memória de trabalho.

O cartão de memória deve permanecer inserido enquanto o programa estiver 
sendo executado.
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Memória de Carga A memória de carga pode ser um cartão externo inserido ou a RAM integrada. 
No S7-400 o cartão de memória (RAM ou Flash EPROM) expande a memória 
de carga integrada. O cartão acaba tornando-se sempre necessário, devido ao 
tamanho limitado da memória de carga integrada.

Memória de Trabalho A memória de trabalho contém apenas os dados relevantes para execução. 
A memória de trabalho RAM está integrada na CPU e é mantida através de 
bateria.

Memória de Sistema A memória de sistema contém áreas de memória para:
• Imagens de processo de entrada e saída (PII, PIQ)
• Bit memories (M)
• Temporizadores (T)
• Contadores (C)
• Pilha local (L stack) (L).

Memory Card Quando um cartão de memória RAM é utilizado, o sistema deve ser operado 
com bateria, para que o conteúdo do cartão e da RAM interna seja mantido em 
caso de falha na tensão de alimentação.
Quando um cartão de FEPROM é utilizado o programa fica nele armazenado, e 
livre de problemas com relação à falha na tensão de alimentação. Os dados 
contidos na RAM interna são mantidos através de bateria.
O modo "Restart" somente é possível em um sistema com bateria.

Inserindo um Após a inserção do cartão de memória, o sistema operacional pede um reset de
Memory Card memória. (O LED STOP pisca vagarosamente). O reset é realizado colocando o 

seletor de modo na posição "MRES". As seções do programa que são 
relevantes para execução são então transferidas do cartão de memória (com a 
função de memória de carga) para a memória de trabalho.

O cartão de memória deve permanecer inserido enquanto o programa estiver 
sendo executado.
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Introdução Utilizando um módulo FEPROM, a CPU pode funcionar sem bateria de backup. O 
programa é armazenado na FEPROM, e fica à prova de falha de tensão de 
alimentação. 
Pode-se definir as áreas retentivas na configuração de HW. No S7-300, os dados 
retentivos (temporizadores, contadores, bits de memória, áreas de dados) são 
armazenados numa área de memória retentiva da CPU (RAM não-volátil).

Inserir / Remover Ao retirar ou inserir um módulo de memória, a CPU pede um reset de memória. Se 
for inserido um módulo de RAM, o programa deve ser recarregado a partir do PG. 
Se for inserido um módulo FEPROM, seu conteúdo é copiado para a memória de 
trabalho. 

Falha de Tensão Após uma falha de tensão sem bateria de backup, os blocos são copiados do 
módulo de memória para a memória de trabalho e, no caso do S7-300, os dados 
retentivos são fornecidos pela RAM não-volátil.
Áreas de dados dos DBs, definidas como retentivas (só para o S7-300), 
apresentam o estado que tinham antes da falha de tensão. As áreas não retentivas 
são levadas aos valores originais armazenados no módulo de memória.

Alterando Ao fazer alterações nos blocos, os blocos modificados são armazenados na
o Programa memória de trabalho. Ao transferir os blocos para o PG, estes são recuperados da 

memória de trabalho.
Após uma falha de tensão (sem bateria), a memória de trabalho (RAM) é apagada. 
Para que os blocos corrigidos estejam mais uma vez disponíveis após o Power On, 
eles devem estar:
1. armazenados no disco rígido no caso de se trabalhar sem módulo de memória 
EPROM.
2. armazenados no disco rígido ou num módulo de memória no caso de se  
trabalhar com módulo de memória EPROM. 

Carregando o  Tanto faz transferir os blocos para o módulo de memória (inserido no PG) 
Memory Card utilizando o SIMATIC Manager arrastando-os com o mouse ou, no caso de algumas 

CPUs, escrever diretamente no módulo utilizando a seqüência de menus PLC -> 
Download User Program to Memory Card. O módulo de memória deve ser apagado 
primeiro.
Os blocos individualmente podem ser recarregados, porém não podem ser 
apagados ou sobrescritos.
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Requisitos O driver para o cartão de memória deve estar instalado no software STEP 7. 
Caso não esteja, clique no menu Iniciar e selecione Simatic -> STEP 7 -> 
Memory Card Parameter Assignment para instalar o driver. Com isso aparecerá 
um ícone para o Memory Card na barra de ferramentas do SIMATIC Manager.
O cartão de memória deve estar apagado antes de se efetuar a cópia do 
programa para dentro dele.

Abra duas janelas no SIMATIC Manager:

• A primeira contendo o programa o qual se deseja salvar

• A segunda com o memory card

Copiando Selecione os blocos desejados ou a própria pasta "Blocks" do disco rígido e 
arraste-os para dentro da janela do Memory Card usando o mouse.

Nota Em algumas CPUs (por ex. a CPU 416), é possível escrever no cartão de 
memória diretamente na CPU. Para isso, use as opções de menu PLC -> 
Download User Program to Memory Card.
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Função Com as funções "Save Project on Memory Card" e "Retrieve Project from 
Memory Card", pode-se salvar e depois ler os dados completos do projeto 
(programas com todos os comentários, tabelas de símbolos, configurações de 
hardware etc. de todas as estações de hardware) no cartão de memória. O 
cartão de memória pode estar na CPU ou no slot de programação do PG ou do 
PC. 

Os dados do projeto são comprimidos antes de serem salvos no cartão de 
memória, e são extraídos quando lidos. O tamanho dos dados do projeto é o 
mesmo tamanho do arquivo correspondente ao projeto. Uma mensagem é 
gerada caso a capacidade de armazenamento do cartão de memória não for 
suficiente.

Dados de Projeto Os dados do projeto contêm – assim como o arquivo do projeto – basicamente
com / sem o todos os dados pertencentes ao mesmo, ou em outras palavras, também todos
Programa os programas das CPUs. Os programas contidos nos dados do projeto podem, 

entretanto, não serem lidos pelas CPUs, e com isso não serem executados. 
Com a opção "Load the user program also", o programa executável também é 
armazenado, juntamente aos dados do projeto. Esse programa é o que está 
associado à CPU na qual o cartão de memória está inserido.

Área de Utilização Se várias pessoas trabalharem com a manutenção de um mesmo PLC 
SIMATIC S7, torna-se difícil mantê-las atualizadas em relação aos dados do 
projeto na hora da manutenção. Se os dados do projeto estiverem disponíveis 
localmente em uma das CPUs, cada pessoa poderá acessar os dados atuais e 
fazer alterações, se necessário, e as alterações por sua vez já estarão 
disponíveis para os outros usuários.

Nota A função Save Project on Memory Card  e  Retrieve Project from Memory Card
atualmente é possível somente nos sistemas S7-400 e nas novas CPUs S7 300 
Standard – CPU 312, CPU 314 e CPU 315-2DP.
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Introdução Se um projeto necessitar de mais do que 1.44 MB de memória, pode-se ainda 
salvá-lo em disquete arquivando-o (comprimindo-o) primeiramente.

Explorer Pode-se verificar o tamanho de um projeto no Windows Explorer:

• Clique na pasta do projeto com o botão direito do mouse e selecione 
Properties

• Selecione a pasta do projeto e depois escolha as opções de menu  
File -> Properties.

Em ambos casos abre-se a janela "Properties".
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Introdução A função para arquivar existe pelo fato dos dados em um projeto poderem ocupar 
muito espaço de memória e não se comportarem em um disquete.
Com essa função os dados são comprimidos de forma a ocupar aproximadamente 
1/8 do tamanho original. Ela utiliza as ferramentas normais de compressão, como 
o PKZIP, ARJ, LHARC, RAR ou WINZIP. Um destes programas deve estar 
instalado no PG. Para utilizar nomes de arquivos mais longos é necessário utilizar 
o PKZIP, WinZip ou RAR.
Os utilitários ARJ e PKZIP são fornecidos juntamente com o STEP 7.

A configuração de localização do programa utilitário de compressão é feita através 
das opções de menu Options -> Customize -> Archive  no SIMATIC Manager.

Arquivando • O projeto a ser arquivado deve estar fechado no SIMATIC Manager.
• Selecione a opção de menu File --> Archive.
• Selecione o projeto a ser arquivado na caixa de diálogo.
• Selecione o nome para o arquivo na próxima caixa de diálogo.
• Na última caixa de diálogo, pode-se escolher entre as seguintes opções:

- Disk-crossing archive =
Divide ou não o arquivo em vários disquetes

- Incremental archiving = 
Apenas os arquivos com o atributo ACR

(arquivos STEP7) são arquivados.

- Reset archive bit = 
Arquiva apenas os arquivos que foram 

modificados desde a última vez que o projeto  
foi arquivado.

- Consistency check = 
Compara os arquivos a serem arquivados 

(apenas para o ARJ)
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Extraindo • Selecione a opção de menu File -> Retrieve.
• Selecione o arquivo.
• Na próxima caixa de diálogo, selecione o diretório para o projeto 
extraído.
• Utilize a última caixa de diálogo para selecionar as opções para 
sobrescrever ou modificar o diretório de 
armazenamento.
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Objetivo Arquivar o “Projeto_1” para salvá-lo em disquete.

Nota Basicamente somente projetos fechados podem ser arquivados. Antes de 
iniciar a função de arquivamento deve-se certificar de que nem o SIMATIC 
Manager e nem as outras aplicações (Editor LAD/FBD/STL, Editor de Símbolos, 
Configuração de HW, etc.) estão acessando o projeto a ser arquivado.

O Que Fazer • Feche o projeto a ser arquivado.

• Inicie a função de arquivamento
File -> Archive -> Project

• Nas caixas de diálogo seguintes determine o projeto a ser arquivado, assim 
como o nome, o diretório de armazenamento e o tipo (*.zip, *.arj , etc.) do 
arquivo.

• Através do Windows Explorer verifique o sucesso da função de 
arquivamento, e compare o tamanho (memória necessária) do projeto 
original e do arquivo.

• Opção:
Copie o arquivo do projeto para um disquete.


